Problem with the second (etc) prompt window

RESOLVED INVALID

Status

()

RESOLVED INVALID
8 years ago
8 years ago

People

(Reporter: boot-net, Unassigned)

Tracking

4.0 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Caused by AlertStopper], URL)

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Opera/9.80 (Windows NT 6.1; U; en) Presto/2.7.62 Version/11.01
Build Identifier: 4.0

When the prompt window is called for the second time (etc), prompt() returns default value even if the button Cancel is pressed (or the window is closed).

Reproducible: Always

Steps to Reproduce:
1. Create a simple page with Javascript, containing prompt() (you should be able to call this function several times and see the value which it returns).
2. Open this page and call prompt() several times to see the result.
Actual Results:  
The function returns the wrong value

Expected Results:  
The function returns the right value )

Comment 1

8 years ago
Please attach a testcase or provide a public URL that exhibits the issue
Version: unspecified → 4.0 Branch

Comment 2

8 years ago
Reporter -> Are you still experiencing this issue? Please attach a testcase of provide a URL that shows the issue
(Reporter)

Comment 3

8 years ago
Created attachment 537966 [details]
An example of promp. Alert shows the value

You may also see how it works here: http://livescript.ucoz.ru/prompt.html
Attachment #537966 - Flags: review+
(Reporter)

Updated

8 years ago

Updated

8 years ago
Attachment #537966 - Flags: review+

Updated

8 years ago
Attachment #537966 - Attachment mime type: text/plain → text/html

Comment 4

8 years ago
WFM on Mozilla/5.0 (Windows NT 5.1; rv:7.0a1) Gecko/20110607 Firefox/7.0a1 ID:20110607030744

If I enter any text in the alert dialog it is shown on the next alert - tried 10x in a row. What are you seeing happen?
(Reporter)

Comment 5

8 years ago
(In reply to comment #4)
> WFM on Mozilla/5.0 (Windows NT 5.1; rv:7.0a1) Gecko/20110607 Firefox/7.0a1
> ID:20110607030744
> 
> If I enter any text in the alert dialog it is shown on the next alert -
> tried 10x in a row. What are you seeing happen?

When you click 'prompt' for the first time, everything is correct. The next window shows you the value returned by function prompt. But if you click 'prompt' for the second time (or more) and choose 'cancel' or just close prompt window, you will see 'works' instead of 'null' (you may compare the result in Chrome, for example)

Comment 6

8 years ago
WFM on Mozilla/5.0 (Windows NT 5.1; rv:7.0a1) Gecko/20110607 Firefox/7.0a1 ID:20110607030744

I can enter text and click OK and I see the text. If I click on cancel the next dialog returns null.

Does the issue still occur if you start Firefox in Safe Mode? http://support.mozilla.com/en-US/kb/Safe+Mode

How about with a new, empty profile? http://support.mozilla.com/en-US/kb/Basic+Troubleshooting#Make_a_new_profile
(Reporter)

Comment 7

8 years ago
(In reply to comment #6)
Thanks a lot! I tested Firefox in Safe Mode and the problem didn't appear.
I found that the reason was the AlertStopper extension.
And yes, the second window returned the right value, but when I continued clicking 'prompt' it caused this mistake.

Comment 8

8 years ago
Please report to the add-on developer and point them to this bug report.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Component: General → Extension Compatibility
QA Contact: general → extension.compatibility
Resolution: --- → INVALID
Whiteboard: [Caused by AlertStopper]
You need to log in before you can comment on or make changes to this bug.