rss add-on "Brief" 1.5.3 causes FF 4 to freeze

RESOLVED WORKSFORME

Status

()

Firefox
Extension Compatibility
RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: f.graver, Unassigned)

Tracking

4.0 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0) Gecko/20100101 Firefox/4.0

Firefox freezes and must be force-quit.  Happens in different circumstances, with different combinations of programs open.  Based on the error message (see below under "additional information") it seems related to the add-on Brief.

The problem is new since updating to Firefox 4.0

Reproducible: Sometimes




Feil: [Exception... "Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIAlertsService.showAlertNotification]"  nsresult: "0x80040111 (NS_ERROR_NOT_AVAILABLE)"  location: "JS frame :: resource://brief/FeedUpdateService.jsm :: FeedUpdateServiceInternal_finishUpdate :: line 263"  data: no]
Kildefil: resource://brief/FeedUpdateService.jsm
Linje: 267
Do you get a crash or a freeze ?
Does it work without the addon ?
(Reporter)

Comment 2

7 years ago
Most recently it was a freeze and I had to use OSX "force quit".

I have uninstalled the addon today, and will try working without for a few days to see if that resolves it.

Updated

7 years ago
Version: unspecified → 4.0 Branch
Adam have you seen this from other users?
(Reporter)

Updated

7 years ago
Summary: rss add-on "Brief" 1.5.3 causes FF 4 to crash → rss add-on "Brief" 1.5.3 causes FF 4 to freeze

Comment 4

7 years ago
Not really. There has been a single somewhat similar report in recent months
and it was about Brief causing Firefox to run out of memory, see
http://brief.mozdev.org/drupal/node/897. Reporter, is this what you're seeing?

That error is unrelated, it's an expected exception that has been caught and
handled. There is no indication that this problem is related to Brief, yet.
(Reporter)

Comment 5

7 years ago
I took a look at that, but it does not seem to be the same error I reported.

I turned off Brief on monday and have been running with FF with no problems since, so I suspect it is somehow related to the add-on and compatibility with FF4.  I have been running Brief for a long time and have never had a problem until I upgraded FF.

Comment 6

7 years ago
Works for me on Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0) Gecko/20100101 Firefox/4.0

Comment 7

7 years ago
Reporter, do you have anything new to add about this issue?
(Reporter)

Comment 8

7 years ago
Now that both Brief (1.5.4) and Firefox (4.0.1) have been updated I am reactivating Brief today.  It hase been off since Apr. 4, and FF has not crashed on either of my Macs in that time.  I will report back.

Comment 9

7 years ago
Reporter, please do so. (comment8)
(Reporter)

Comment 10

7 years ago
The respective updates to Brief and Firefox seem to have taken care of the issue.  There have been no crashes or abnormalities (related to Brief) on either of my machines since my last report.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.