Closed Bug 648849 Opened 10 years ago Closed 10 years ago

TI: SIGTRAP with try/catch/finally

Categories

(Core :: JavaScript Engine, defect)

x86_64
Linux
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 646267

People

(Reporter: decoder, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: crash, testcase)

The following testcase causes SIGTRAP on TI revision d3215d1e985a (run with -m -n -a), tested on 64 bit:

function expectThrowTypeError(fun)
{
  try {
    fun()
  } catch (e) {}
}

expectThrowTypeError(function() {  });
expectThrowTypeError(function() {  });
expectThrowTypeError(function() {  });
expectThrowTypeError(function() {
    try {  
      } finally {
      }
  });
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 646267
A testcase for this bug was already added in the original bug (bug 646267).
Flags: in-testsuite-
You need to log in before you can comment on or make changes to this bug.