Recently closed tabs and windows are never deleted when history is deleleted

RESOLVED WORKSFORME

Status

()

Firefox
Session Restore
RESOLVED WORKSFORME
7 years ago
11 months ago

People

(Reporter: Patrick, Unassigned)

Tracking

14 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: DUPEME?)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.0; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Windows NT 6.0; rv:2.0) Gecko/20100101 Firefox/4.0

This bug only seems to occur once the session gets a little older. About a week is enough for the bug to trigger.

You can only see that it triggered when you finally notice that the lists of Recently closed tabs and windows cannot be cleared anymore using the "remove all history" pannel (CTRL+SHIFT+SUPPR), even with all options selected.

The only way I found to wipe these two lists is to delete the entire session.

Expected behaviour: The user has a session opened with many tabs and Panorama tab groups. He is privacy concious though, and he frequently deletes his tracks using CTRL+SHIFT+SUPPR. This includes all history and previous navigation, however he did kept all these tabs opens, which means he does not want them deleted; He wants their URLs to keep being stored in sessionstore.js along with their order, the tab group they belong to as well as their window.
By keeping these tabs open while clearing all history, he expects ALL data to be erased, of any kind, except what is stated above.


Recently closed tabs and windows, also stored within sessionstore.js, stops being erased after the bug occur and until the session is just wiped entirely.


(Eventual bug that is unrelated: Panorama's cache can't seem to be cleared with regular cache (?) )


Finally, I don't know what triggers this bug.
For information, I have cache and history disabled and only rely on the "recently closed ___" list to get back to lost tabs. I set it so that 30+ tabs are remembered (default is 10) and 6 windows (default is 3).

Reproducible: Always

Steps to Reproduce:
1. Keep using the same session for a week or so
2. Close firefox and your computer every day
3. Notice how at some point, recently closed tabs and windows stop being deleted with other private data
Actual Results:  
Stuck with a large list of recently close items

Expected Results:  
I clear my private data, they should vanish with everything else but my CURRENTLY opened tabs and windows and their organization in Panorama (only the URLs are stored, previous page/next page/cache/anything related to them should vanish)

I'm using the default theme, and AdBlockPlus, NoScript and CookieMonster as addons.

A couple more addons are installed but disabled. Plugins are the bare minimum, nothing fancy.

Updated

7 years ago
Version: unspecified → 4.0 Branch

Updated

7 years ago
Component: Bookmarks & History → Session Restore
QA Contact: bookmarks → session.restore
This sounds like it could be a DUPE of bug 644998.
Whiteboard: DUPEME?

Comment 2

5 years ago
I am experiencing this bug with Firefox 14.0.1, so it's not a dupe of bug 644998.

Comment 3

5 years ago
I have just reproduced the bug after restarting with add-ons disabled, which suggests but does not prove that it is not add-on-related.
OS: Windows Vista → All
Hardware: x86 → All
Version: 4.0 Branch → 14 Branch
Please try with a new profile and Firefox 18.0a1 Nightly (nightly.mozilla.org).

Comment 5

5 years ago
I can confirm this bug for 15.0.1. (on linux)

After a session of six days, with a new profile, recently closed tabs/windows are not deleted anymore.

Default theme and no addons.
Marco, can you comment on this bug as per comment 5? Would it help to get Cem's sessionstore.bak file?

Comment 7

5 years ago
Hello

Unfortunately I still have this bug with 20.0.1 after resetting Firefox.

Probably I should mention that I use the setting: Startup - Show my windows and tabs from the last time.

I didn't try with a completely new profile.

Comment 8

5 years ago
I'm experiencing the same issue, and the only way to get a smaller session restore file is to create a completely new session or profile, neither of which I don't want, because that would destroy previously saved tabs and tab groups, AFAIK.

I'm using a profile with probably a hundred or so tabs that are not loaded until I click on them, and a large number of tabs reside in tab groups.

I understand that closed, but never-to-be-used tabs are still saved in the session restore file, as about:memory has shown.

There is no way for me to purge (forever delete) a closed tab (or window) that I really don't need and which doesn't have much browsing history in it, and it's also impossible to delete them from session restore history. — This is the kind of functionality I'd like, so as to clean up my session restore data and not unwillingly expand its size any further.

One proposition is a right-click option in the window/tab UI to purge the tab; this would include 'restored' tabs, the browsing history of which I review through back/forward buttons and then delete for cleanup.

A more fine-grained option is to make closed tabs and their histories reviewable in a Library-like UI for even faster cleanup.

Firefox 20.0.1, Windows XP SP3.

Comment 9

4 years ago
For me this seems to be resolved, finally. v27.0.1

It's working as expected.

Thanks

Comment 10

2 years ago
(In reply to Cem from comment #9)
> For me this seems to be resolved, finally. v27.0.1
> 
> It's working as expected.

Do others agree?
Flags: needinfo?(martrootamm)
Flags: needinfo?(a331133)

Comment 11

2 years ago
(In reply to Wayne Mery (:wsmwk, use Needinfo for questions) from comment #10)
> (In reply to Cem from comment #9)
> > For me this seems to be resolved, finally. v27.0.1
> > 
> > It's working as expected.
> 
> Do others agree?

What's the resolution?
Flags: needinfo?(martrootamm)

Comment 12

2 years ago
(In reply to Mart Rootamm from comment #11)
> (In reply to Wayne Mery (:wsmwk, use Needinfo for questions) from comment
> #10)
> > (In reply to Cem from comment #9)
> > > For me this seems to be resolved, finally. v27.0.1
> > > 
> > > It's working as expected.
> > 
> > Do others agree?
> 
> What's the resolution?

Good question Mart. We have:
* one abstention - you didn't comment affirmative or negative
* one fixed - Cem
* no response - Patrick, the reporter

That said, I reread comment 0 and it's not clear to me that clearing session store was ever a designed to be integrated with clearing history or privacy data.  So I think this bug is a duplicate of bug 803806.  What do you think?

Without respect to History and privacy, session file size is addressed by bug 989393 fixed mid-2014 and bug 943352 which intends to go further.  And a workaround to reducing size is to do about:sessionstore then click "forget closed tabs" and "forget closed windows".  FWIW http://mzl.la/1p592gr is a more comprehensive list of bugs from the past 2 years.
Summary: Recently closed tabs and windows are never deleted unless I wipe the whole session with them → Recently closed tabs and windows are never deleted when history is deleleted
I'm going to close this one out. Please re-open if people are still seeing this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME

Updated

11 months ago
Flags: needinfo?(a331133)
You need to log in before you can comment on or make changes to this bug.