Closed Bug 648886 Opened 9 years ago Closed Last year

Non-functioning and confusing UI for keyboard shortcuts

Categories

(Penelope Graveyard :: Mail Window, defect)

x86
Windows Vista
defect
Not set

Tracking

(Not tracked)

RESOLVED WONTFIX
Eudora OSE 1.0.1

People

(Reporter: aweissberg, Assigned: mdudziak)

References

(Blocks 1 open bug)

Details

User-Agent:       Mozilla/5.0 (Windows NT 6.0; WOW64) AppleWebKit/534.24 (KHTML, like Gecko) Chrome/11.0.696.34 Safari/534.24
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.9) Gecko/20100722 Eudora/3.0.4

Keyboard shortcuts that appear with right-click on message don't work.  For example, right-click a message and see Mark (with the k underlined) but ctrl-K doesn't bring this up.  Then next menu includes Add Star with the S underlined but no way to use keyboard to add a star.  Also there seems to be multiple shortcuts for the same key combinations, for example ctrl-K (see above) and also is for create new contact.

Reproducible: Always
Underlines don't indicate keyboard shortcuts. They indicate menu accelerators. That is, if you're in a menu and see an underlined letter, press that key (and only that key) to activate the item.

If you're looking for keyboard shortcuts to be used outside of the menus, they aren't listed in the context menus, but in the main menus at the top of the window (e.g. the Message menu).
Thanks for explaining that.  Now, how about adding Mark (that you get in a right-click on a message) to the main menu so it can be accessed via a keyboard shortcut?
It should already be there.

Note that if you're using Thunderbird 3.3, the shortcut isn't displayed, but it's "M". There's not an easy way to show it, since there are two menu items (mark read and mark unread), and "M" toggles between the two. This doesn't apply to versions before 3.3, though.
Thanks again.  But I'm using Eudora 1.0 OSE
Assignee: nobody → mozilla-bugs
Component: Mail Window Front End → Mail Window
Product: Thunderbird → Penelope
QA Contact: front-end → mail-window
Target Milestone: --- → Eudora OSE 1.0.1
Penelope didn't see any activity in the vcs for the last 8 years, closing.
Status: UNCONFIRMED → RESOLVED
Closed: Last year
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.