Emptyting cache or setting cache limit below cache size can hang the application for minutes, delete/remove files in background

VERIFIED DUPLICATE of bug 670911

Status

()

Core
Networking: Cache
VERIFIED DUPLICATE of bug 670911
7 years ago
7 years ago

People

(Reporter: aryx, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Mozilla/5.0 (Windows NT 5.1; rv:2.0) Gecko/20100101 Firefox/4.0

Emptyting cache or setting cache limit below cache size can hang the application for minutes, delete/remove files in background.

Steps to reproduce:
1. Use default (dynamic cache) with some space free on the disk (here 20 GB). Cache size was 620 MB.
2. Go to menu Tools > Options > Advanced > Network and click the Empty Cache button.

Actual result:
The application is blocked until the cache has been emptied. This took 6 minutes.

Expected result:
Do emptying cache in background (for the frontend people: maybe with doorhanger).

The same issue happens if you set a lower cache size limit (tried with 80 MB).

Comment 1

7 years ago
There seem to be two causes of this.  

First of all, when I examine the cache files, I find 16 primary folders, each with subfolders, and each subfolder containing only one file.  One fire per folder is very inefficient.  (Perhaps I have not accumulated sufficient files in my cache to get more than one file per subfolder, but even this small amount takes several seconds to delete.)  

Then for deleting the cache, it appears that Gecko is examining each of the 16 primary folders and deleting its subfolders.  It would be far more efficient if the primary folders and their contents were merely deleted.  The primary folders would then be regenerated with the next use of the browser.
Thanks for the bug report!

This has been fixed, and will show up in FF8.

See bug 687232 comment 5 for briefest description of the issue--it's an NTFS permissions issue with renaming directories.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 670911
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.