Last Comment Bug 648898 - Remove the xptinfo tests we don't want to bother running
: Remove the xptinfo tests we don't want to bother running
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: XPCOM (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla6
Assigned To: Phil Ringnalda (:philor, back in August)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-10 13:25 PDT by Phil Ringnalda (:philor, back in August)
Modified: 2011-04-15 20:29 PDT (History)
0 users
philringnalda: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
rm (6.73 KB, patch)
2011-04-10 13:25 PDT, Phil Ringnalda (:philor, back in August)
benjamin: review+
Details | Diff | Splinter Review

Description Phil Ringnalda (:philor, back in August) 2011-04-10 13:25:24 PDT
Created attachment 524989 [details] [diff] [review]
rm

Every time we package tests, the step ends with

tar: xpcom_typelib_test.jar: Cannot stat: No such file or directory
tar: Error exit delayed from previous errors

because we didn't tell http://mxr.mozilla.org/mozilla-central/source/testing/xpcshell/Makefile.in#86 about it when http://hg.mozilla.org/mozilla-central/rev/0a7b778b97a3 decided they weren't worth the trouble to make work with manifests, and commented out coming near them.

It's going on a year later, so a hypothetical person who hypothetically wants to rewrite them to work and hypothetically wants to look at how they used to be done has thousands of csets he can pass to "hg up -r" in order to see them. The rest of us don't need to see false positives in searches, or see it failing to be packaged, or to think we test something because we don't see the #'s two directories up the line.
Comment 1 Phil Ringnalda (:philor, back in August) 2011-04-15 20:29:55 PDT
http://hg.mozilla.org/mozilla-central/rev/d2259dd3da34

Note You need to log in before you can comment on or make changes to this bug.