Closed Bug 648916 Opened 9 years ago Closed 9 years ago

mobile builds need to use Mercurial build step

Categories

(Release Engineering :: General, defect)

ARM
All
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 557260

People

(Reporter: philor, Assigned: aki)

Details

(Whiteboard: [mobile])

Since mobile appeared to have been broken by something in a merge of a dozen csets, we tried to trigger two builds, a rebuild of one build on http://hg.mozilla.org/mozilla-central/rev/352ebc13e546 from before the bustage to see if that rev remained good, and a new whole build round on http://hg.mozilla.org/mozilla-central/rev/233dde6c5b44 from the middle of the merge.

Both just wound up giving us extra builds on the rev that was the tip of mozilla-central at the time.
See bug 648918 comment 2 through bug 648918 comment 5 for a discussion of what seems like the likely cause here.
Assignee: nobody → aki
Whiteboard: [self-serve][mobile]
Potential fixes:

a) Just replace the hg commandlines for the mozilla repo with a Mercurial build step. This may break some existing functionality -- force clobbers, potentially might not play well w/ scratchbox ?
b) Go with jhford's inherit-MercurialBuildFactory patch, which is still ~ >1week away. This can fix a lot, but is a fairly large change; I'm not sure how much this may break (the scope of what might break is most likely a superset of what would break in option a).
c) Migrate AndroidBuildFactory and MaemoBuildFactory fully to mozharness, and make sure whatever factory that calls it adds a --clobber and/or --revision based on properties/clobberer when needed.
Summary: Self-serve retriggers mobile builds on the tip rev, rather than the triggered rev → mobile builds need to use Mercurial build step
Whiteboard: [self-serve][mobile] → [mobile]
(In reply to comment #2)
> Potential fixes:
> 
> a) Just replace the hg commandlines for the mozilla repo with a Mercurial build
> step. This may break some existing functionality -- force clobbers, potentially
> might not play well w/ scratchbox ?
> b) Go with jhford's inherit-MercurialBuildFactory patch, which is still ~
> >1week away. This can fix a lot, but is a fairly large change; I'm not sure how
> much this may break (the scope of what might break is most likely a superset of
> what would break in option a).
> c) Migrate AndroidBuildFactory and MaemoBuildFactory fully to mozharness, and
> make sure whatever factory that calls it adds a --clobber and/or --revision
> based on properties/clobberer when needed.

a) is going to be about as much work as b), imo.  I am going to be looking at the MercurialBuildFactory stuff later on today.
(In reply to comment #2)
> Potential fixes:
> 
> a) Just replace the hg commandlines for the mozilla repo with a Mercurial build
> step. This may break some existing functionality -- force clobbers, potentially
> might not play well w/ scratchbox ?
> b) Go with jhford's inherit-MercurialBuildFactory patch, which is still ~
> >1week away. This can fix a lot, but is a fairly large change; I'm not sure how
> much this may break (the scope of what might break is most likely a superset of
> what would break in option a).
> c) Migrate AndroidBuildFactory and MaemoBuildFactory fully to mozharness, and
> make sure whatever factory that calls it adds a --clobber and/or --revision
> based on properties/clobberer when needed.

d) use hgtool.py
Going to do this as part of the mobile->mercurialbuildfactory work
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 557260
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.