Page was truncated while using Open File...

VERIFIED INVALID

Status

()

VERIFIED INVALID
18 years ago
17 years ago

People

(Reporter: franklin, Assigned: karnaze)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Using the File Open under File menu to open a html file,
The file will be truncated.
But using the http protocol to browse the same file,
the page will NOT be truncated.
For example: http://linuxt3.hyweb.com.tw/network.html
This is a tutorial page written by me, teaching others
in my company the basic network configuration on Linux.
You can try to save it as a local file, and use File/Open File to open it. It
will be truncated.
(At least I have tried for times, all failed to see the completed page.)

Comment 1

18 years ago
*** Bug 64910 has been marked as a duplicate of this bug. ***

Comment 2

18 years ago
Please always include mozilla build ID in bug-reports.
(Reporter)

Comment 3

18 years ago
Sorry, its Build ID is 2001010517

Comment 4

18 years ago
unable to reproduce with win32 or linux builds from today 011008.  I visited the
URL and saved that html to file then loaded it with File|Open File and it was
displayed exactly the same as it was remotely.
(Reporter)

Comment 5

18 years ago
Sorry, but I have tried for many times. The bug was still there.
Now I found that I can see the completed page ONLY IF I added a <tr></tr> BEFORE
a table (the table in about line 93), even the <tr></tr> was not in the table.
Otherwise it would be truncated after the (line-93) table.
I wonder if this bug was caused the abnormal processing of tables.

Comment 6

18 years ago
over to HTML Tables for further triage. 
Assignee: asa → karnaze
Component: Browser-General → HTMLTables
QA Contact: doronr → chrisd

Comment 7

18 years ago
that makes no sense at all.. there is another reason that we have to discover,
putting tr's outside tables is just not right (and shouldn't be a workaround)

Comment 8

18 years ago
This maybe a cache or proxy problem. Reporter are you running through a proxy?
Does this occur with the latest nightly builds and with a new profile? 
(Reporter)

Comment 9

18 years ago
1. No, I did not set any proxy server.
2. Sorry, I don't really know what you mean.
   I used the build 2001010517, and did not change anything in profile.
(Actually I don't know where the profile is.)
   If this is not what you mean, please tell me what you want to know.

Comment 10

18 years ago
I mean start mozilla with the commandline 'mozilla -profilemanager' and create a
new profile. Try to see if the problem repeats. Thanks.
(Reporter)

Comment 11

18 years ago
Sorry, still no use.
I created a new profile and tried again, still no use.
But this time I saw a message on console:

``we don't handle eBorderStyle_close yet... please fix me''

I don't know what it means and don't know if it was the reason for the problem I
met.

I also tried for different locales but nothing different.

Comment 12

18 years ago
Ok that has nothing to do with it. I am going to go ahead and mark this NEW.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 13

18 years ago
Please try to browse this link:

http://linuxt3.hyweb.com.tw/network.html

This time I did not use File/Open but use http:// instead, and it was truncated too.
I don't know if it would be truncated when you browse.

My env:
build ID: 2001010517
locale: zh_TW.Big5
Linux Mandrake 7.0, kernel 2.2.14-15mdk
linuxt3.hyweb.com.tw is using apache-1.3.12-2
the network.html is using Big5 encode.

Comment 14

18 years ago
QA contact update
QA Contact: chrisd → amar
URL has died and not apparently reproducible...closing INVALID.  Reporter: if
you are still seeing this problem, reopen the bug and attach a testcase.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID

Comment 16

17 years ago
 Marking invalid since lack of response and URl does not exit or it does not work
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.