Two of three vertically stacked drop-downs at center screen do not initiate events.

RESOLVED WORKSFORME

Status

()

Firefox
General
--
major
RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: Jerry, Unassigned)

Tracking

({qawanted, regression})

5 Branch
x86
Windows XP
qawanted, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [login account needed], URL)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0) Gecko/20100101 Firefox/4.0

After logging into Accounts page, I will have three drop-downs in the top half of the screen, one for each account (two trading, one banking):  The three drop-downs are each stacked vertically and grouped closely; one trading account drop-down at top, another at center, then banking at the bottom.

That physical arrangement seems to matter.

The two top pull-downs, having 10 choices each, work only in the sense that I can scroll through their lists and select an item.  Nothing happens upon selection -- with either mouse or keyboard.

The bottom pull-down, for banking, has fewer choices but works.

On the bottom half of that page there are drop-downs related to bank transfers.  They all seem to work but I don't want to test them to their end for obvious reasons.

Other pull-downs on other pages work.  At least I haven't found any that don't.  But that's not an exhaustive search.

This is repeatable without exception.  Running in Safe Mode makes no difference.



Reproducible: Always

Steps to Reproduce:
1. I think my details covers it pretty well.
2.
3.
Actual Results:  
Ditto above.

Expected Results:  
The expected results are that the screen should move to another page of the site based on the selection.  Given that I watch the LAN status window, nothing is transmitted out so Firefox isn't recognizing any event during drop-down selection.

With the exception of having very few add-ons, I'm using FF as it came out of the box.  I'll repeat that I've tested in Safe Mode and it makes no difference.

I've had lots of problems with older versions of FF, and all seem to be related to cache and history.  That's one of the reasons I have a flush-cache button added to the tool bar.  There still seems to be cache problems, as it tends to confuse FF about where it’s been and where it should be going.

I'm marking Severity as Major, below, because I'm a stock trader and these issues with navigating my brokerage account, and having to occasionally flush cache to get out of a locked situation has at times cost me quite a bit of money.
If you select an item and then press TAB, does that make a difference?

Updated

7 years ago
Version: unspecified → 4.0 Branch
(Reporter)

Comment 2

7 years ago
Mats ... I tried your suggestion.  Nothing happens.  No other key, or combination of keys, or mouse buttons do anything with the top two drop-downs.

I use drop-downs in my own software using VBA, so I tried an additional test on the bottom drop-down (of the group of three) that does work.  I selected one of the 10 pages from that drop-down, noted that the process of requesting data for the selected page immediately started, then I canceled that action so that I remained on the page I was on.  I did this so quickly that there was no change to the page.  On the attempt to make the same selection from the drop-down, there was no action.  Other pages could be selected, and a page load would be initiated.  If I canceled the next selection (as I did with the first selection), then I could reselect the first selection but not the last selection.  This is repeatable over and over.
Do you see any error messages in the Error Console in Firefox?

There's not much I can do for you without seeing the HTML/CSS/JS used
on the page.  If you "File->Save Page As" and select "Web page, complete"
in the dialog, can you reproduce the problem using the saved copy of the
page?

In any event, please report the problem to the web admin at us.etrade.com
to make them aware of it (with a link to this bug report).
Maybe the problem is in their code.
Whiteboard: [login account needed]
(Reporter)

Comment 4

7 years ago
Mats,

No error reported.  Screen just acts dead when trying to use the top two drop-downs, yet the bottom drop-down works fine.

I saved the page as a complete Web page (with Firefox), then loaded it back into Firefox.  Did that twice.  The three drop-downs don't work any differently.  The screen, as a whole, looked similar but still quite a bit different from the original screen (which remained active in a different tab).  I reloaded the page from the address bar, and the result looked different yet again.  Otherwise, yes, the problem is reproduced, and a few of the other things I tried on the page seemed to work.

I will call E*Trade and report the problem -- even though I don't like to do that.  You ought to know that I have no significant problems at the E*Trade site with earlier versions of Firefox, and the same is true while using MS Internet Explorer.  I'll let you know what they say or offer to do.  In exchange, would you please try to find another Firefox developer who also has an account at E*Trade, as I think it would be worthwhile seeing what that person experiences while at that site.  There should be a way to broadcast this request out to other Firefox developers/contributors.

The other reason I have qualms about getting E*Trade directly involved is that I have seen that there are a whole lot of bug reports involving drop-down lists and Firefox 4.0.

I'm probably writing to the wrong guy, but I have a suggestion:  Bugzilla Leadership, whomever they are, might find it worthwhile setting up a poling system whereby interested people could sign up as volunteer testers providing the tests are kept simple and didn't involve a lot of time.  For instance, I would sign up, and as a result I might receive an email one sunny day asking me to go to the E*Trade site and try an experiment and report back what I discovered -- and that would be the limit of what I would be asked to do.  It would be known that I should be asked about that assignment because, as part of signing up for this service, I would fill out a short form listing all the sites I commonly visit.

Comment 5

7 years ago
Reporter -> Are you still experiencing this issue with the latest version of Firefox 5?
(Reporter)

Comment 6

7 years ago
Tim, 

Yes, and I have new details which should be useful:

1)  Of the three drop-down lists, the top two are the ones that don't work.  The bottom one works perfectly.  

2)  The top two contain 9 other choices (not counting the top entry, which is the name of the list) and also contain 3 separation bars.  The last item in the list is the only item that works.  That seems significant to me.  Too bad, though -- I'm never interested in going to the destination of the last item from the page that these lists are on.  These two lists display identical choices, but the destinations would be different because these two lists each represent a different stock trading account (Individual and IRA, or SEP).

3)  The third, or bottom, list has 6 other choices and no separation bars.  Every item in the list works.

4)  Throughout the E*Trade site there are many drop-down lists, but the vast majority only contain 2 choices: my two trading accounts.  There are two drop-downs on the Transaction History page that have a very large number of items in their lists.  These lists work perfectly but are different in the way they operate: unlike the two mentioned above, these do not automatically create an action after a selection -- there is a separate Action button.  The same is true on the trading page:  several lists containing several choices, but making a selection invokes no action as there is a separate Action button.
Jerry, did you get a response from the etrade.com people?

I'm sorry but I don't think we'll get anywhere on this problem without
an etrade.com account so we can look at it first hand.

Chris, do we have a contact at etrade.com?
Keywords: qawanted

Updated

7 years ago
Version: 4.0 Branch → 5 Branch

Comment 8

7 years ago
I don't have any contacts there anymore.  kev?
(Reporter)

Comment 9

7 years ago
(In reply to comment #7)
> Jerry, did you get a response from the etrade.com people?
> 
> I'm sorry but I don't think we'll get anywhere on this problem without
> an etrade.com account so we can look at it first hand.
> 
> Chris, do we have a contact at etrade.com?

Mats, 

Yes, I got a response.  They wrote on 04/26/2011:

"The issue regarding Mozilla has already been reported and we are currently working to resolve this. There is no turn around time yet at the moment ... An option for you right now is to use a different browser such as Google Chrome, Internet Explorer or you may revert back to the old version of Mozilla which is Mozilla Firefox 3.6."

I've heard nothing more, but that doesn't mean that they haven't found a fix -- it might only mean that they do not like doing frequent updates.  I imagine that someone at Mozilla could contact E*Trade then ask if the problem has been fixed at their end (but not released), then ask what the issues were, then apply that information to fix Firefox so that it acts more like the browsers that don't have the problem.
Thanks Jerry, that's useful information.  It worries me that it works in
Firefox 3.6 (and other browsers) but not in 4.0.  Can you please ask
them to send an email to mpalmgren@mozilla.com explaining what the
technical problem is so that we can evaluate if it's something we need
to fix at our end?  Thanks for your help.
Keywords: regression
(Reporter)

Comment 11

7 years ago
(In reply to comment #10)
> Thanks Jerry, that's useful information.  It worries me that it works in
> Firefox 3.6 (and other browsers) but not in 4.0.  Can you please ask
> them to send an email to mpalmgren@mozilla.com explaining what the
> technical problem is so that we can evaluate if it's something we need
> to fix at our end?  Thanks for your help.

Mats,

I suppose this means I should have been more exact in my original bug report.  In that report I identified version 4.0 and none of the earlier versions because 4.0 was the most recent version at that time and the problem did not exist in the earlier version -- in fact, in no other version going way back.  Also, I had already tested IE so I knew it is a FF problem (by my definition of where responsibility belongs).  Because of my faulty assumption regarding the understanding that the problem only existing in FF 4.0, it would be clear that no other browser would have that problem.

I have just sent E*Trade a message and phrased it in the manner that appeals to me (being a programmer, but with no experience with browser design) -- which is that it is a browser problem, not a destination-page problem.  So they may not yet know what the problem is.  Also, I am trying to get them to talk to you directly rather than through me.  This is what I sent:

"Regarding this issue, FF4.0 has been upgraded to FF5.0 and the problem still exists.  I have been asked by Mats Palmgren at Mozilla to have a software developer at E*Trade contact him at mpalmgren@mozilla.com for the purpose of helping to resolve this issue.

The Mozilla bug report number is 649141.  The title of the report is 'Two of three vertically stacked drop-downs at center screen do not initiate events.'

Thanks in advance."

Mats, if you want to test some code from my location, feel free to email it to me along with instructions of what to do and look for.  Perhaps that way we could do some joint experiments on that page.

- - - - 

Not that it matters, but it might be bizarrely related ... There is a FF bug that I haven't reported yet:  on virtually every page that is longer than can be displayed on a single screen, holding down the left mouse button while at the top of the screen and then dragging the mouse downward to the bottom of the screen will not result in the screen scrolling upward as the bottom is reached, thereby making it impossible to highlight an entire page that is longer than that which can be displayed at one time.  However, doing the exact opposite -- that is, moving the scroll tab first, in order to display the bottom of the screen, then pressing the left mouse button at the very bottom of the screen and dragging the mouse upward does cause the entire screen to scroll down as the mouse reaches the top, thus allowing the entire contents of the page to be highlighted.  In other words, highlighting screen contents works from bottom-up but not from top-down when the page is longer than the screen.  That is also true for FF4 and FF5 but not true for earlier versions, and it is true for virtually all destination pages.  Clearly then, this problem is also not true for other browsers.  

My guess is that this problem will likely not have anything to do with the other problem and that it has something to do with the mathematics of determining mouse pointer location and the improper handling of the polarity of the result of those math operations.

Comment 12

7 years ago
Jerry -> Any update? Did you ever get a reply from E*Trade?
(Reporter)

Comment 13

7 years ago
(In reply to Tim (fmdeveloper) from comment #12)
> Jerry -> Any update? Did you ever get a reply from E*Trade?

No Feedback from anyone, E*Trade or Mozilla.  Not surprised.

The problem does not exist anymore, though; so somebody fixed something.

Still having the mouse scroll problem, though, mentioned at the end of my last message.
I never heard from E*Trade either.  Glad to hear they have fixed the issue.
Please let us know if it occurs again.

The scrolling issues while drag-selecting is a known problem,
see bug 644621, bug 675865 etc.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 15

7 years ago
(In reply to Mats Palmgren [:mats] from comment #14)
> I never heard from E*Trade either.  Glad to hear they have fixed the issue.
> Please let us know if it occurs again.
> 
> The scrolling issues while drag-selecting is a known problem,
> see bug 644621, bug 675865 etc.

Mats, thanks for the feedback.  I scanned those bug reports.

I'm quite surprised that the scroll problem exists in the first place -- it's part of a general set of mouse tasks which, once developed and tested and modularized, should never again be touched.
You need to log in before you can comment on or make changes to this bug.