Last Comment Bug 649373 - Remove "Alpha #" from blank window titles for Nightly and Aurora
: Remove "Alpha #" from blank window titles for Nightly and Aurora
Status: VERIFIED FIXED
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: unspecified
: All All
: -- normal (vote)
: Firefox 5
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on: 663841
Blocks: 648368 649587 657882 658083 658227 943733
  Show dependency treegraph
 
Reported: 2011-04-12 09:39 PDT by christian
Modified: 2013-11-26 20:25 PST (History)
16 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Alpha 2 in the title (36.06 KB, image/png)
2011-04-12 09:41 PDT, christian
no flags Details
Wallpaper patch that kills "Alpha #" from the window title (2.37 KB, patch)
2011-04-12 21:56 PDT, christian
no flags Details | Diff | Splinter Review
Wallpaper over PRE_RELEASE_SUFFIX by setting it to the empty string (841 bytes, patch)
2011-04-12 22:26 PDT, christian
robert.strong.bugs: review-
Details | Diff | Splinter Review
Wallpaper over PRE_RELEASE_SUFFIX by setting it to the empty string (1.56 KB, patch)
2011-04-12 23:09 PDT, christian
robert.strong.bugs: review+
Details | Diff | Splinter Review
Wallpaper over PRE_RELEASE_SUFFIX by setting it to the empty string, v4 (2.59 KB, patch)
2011-04-12 23:20 PDT, christian
robert.strong.bugs: review+
Details | Diff | Splinter Review

Description christian 2011-04-12 09:39:11 PDT
Aurora blank windows have "Alpha 2" in the title. Aurora will always have [version]a2 as its version. We should remove the "Alpha 2"
Comment 1 christian 2011-04-12 09:41:45 PDT
Created attachment 525410 [details]
Alpha 2 in the title
Comment 3 Phil Ringnalda (:philor) 2011-04-12 11:35:03 PDT
My understanding from #developers is that the actual summary should be "Drop the whole PRE_RELEASE_SUFFIX thing."

mozilla-central will always be n.0a1, never pre, and never released or branded, so a screenshot with "Nightly" in the titlebar can't be confused with anything; mozilla-aurora will always be n.0a2, never pre, never branded, and we're fine with having no way to tell the difference between a screenshot of a shipped Aurora and a tinderbox-build Aurora; mozilla-beta will always be n.0, never pre, always branded, and we're fine with having no way to tell the difference between a screenshot of the very first tinderbox-build from mozilla-beta and the final release of Firefox n.0.
Comment 4 christian 2011-04-12 11:47:39 PDT
Correct.
Comment 5 Ben Hearsum (:bhearsum) 2011-04-12 11:51:47 PDT
http://mxr.mozilla.org/mozilla-central/source/toolkit/mozapps/installer/package-name.mk#115 is what does the conversion, I believe.
Comment 6 Phil Ringnalda (:philor) 2011-04-12 11:57:43 PDT
Yeah, I would have missed that, since it's probably the one place that doesn't use PRE_RELEASE_SUFFIX.

Also, http://mxr.mozilla.org/comm-central/source/mozilla/browser/installer/windows/nsis/defines.nsi.in#37 - do we want Aurora Windows installs to find and clobber a Firefox install? How about Beta?
Comment 7 christian 2011-04-12 12:05:17 PDT
Adding Mayumi, my understanding is that is what we want.
Comment 8 My 2011-04-12 12:30:30 PDT
Yes, for Aurora, Beta and Release, whatever the user downloads most recently trumps the existing install e.g., if I install Aurora and I already have Firefox 4 then Aurora replaces Firefox 4.  Then when the Beta comes out and I download Beta then it replaces Aurora.
Comment 9 christian 2011-04-12 21:56:30 PDT
Created attachment 525615 [details] [diff] [review]
Wallpaper patch that kills "Alpha #" from the window title

tryserver builds can be found at http://ftp.mozilla.org/pub/mozilla.org/firefox/tryserver-builds/clegnitto@mozilla.com-8868b8ea1454/tryserver-macosx64/.

The issue happens on both m-c and m-a.
Comment 10 christian 2011-04-12 22:26:40 PDT
Created attachment 525622 [details] [diff] [review]
Wallpaper over PRE_RELEASE_SUFFIX by setting it to the empty string
Comment 11 Robert Strong [:rstrong] (use needinfo to contact me) 2011-04-12 22:38:27 PDT
Comment on attachment 525622 [details] [diff] [review]
Wallpaper over PRE_RELEASE_SUFFIX by setting it to the empty string

I believe the package-name.mk is still necessary.

You also need to do
http://mxr.mozilla.org/mozilla-central/source/browser/base/Makefile.in#65
Comment 12 christian 2011-04-12 23:09:49 PDT
Created attachment 525630 [details] [diff] [review]
Wallpaper over PRE_RELEASE_SUFFIX by setting it to the empty string

Ok, searched in mxr this time.
Comment 13 Robert Strong [:rstrong] (use needinfo to contact me) 2011-04-12 23:12:50 PDT
Comment on attachment 525630 [details] [diff] [review]
Wallpaper over PRE_RELEASE_SUFFIX by setting it to the empty string

This is good for now for the installer and in app strings. Still need the package-name.mk changes as stated in comment #11.
Comment 14 christian 2011-04-12 23:20:59 PDT
Created attachment 525632 [details] [diff] [review]
Wallpaper over PRE_RELEASE_SUFFIX by setting it to the empty string, v4
Comment 15 Robert Strong [:rstrong] (use needinfo to contact me) 2011-04-12 23:23:14 PDT
Comment on attachment 525632 [details] [diff] [review]
Wallpaper over PRE_RELEASE_SUFFIX by setting it to the empty string, v4

This looks fine!

releng should be given a heads up about the name changing
Comment 16 christian 2011-04-12 23:25:07 PDT
CC'd.
Comment 17 christian 2011-04-12 23:47:03 PDT
Wallpaper pushed to m-c in http://hg.mozilla.org/mozilla-central/rev/5542d52a4832. If green, I'll push to aurora.
Comment 18 christian 2011-04-13 00:46:17 PDT
Also pushed to mozilla-aurora: 
   http://hg.mozilla.org/mozilla-aurora/rev/0e4308feb597
Comment 19 AndreiD[QA] 2011-04-22 04:29:16 PDT
Works For Me on the following builds:

Win7: 
Mozilla/5.0 (Windows NT 6.1; rv:6.0a1) Gecko/20110421 Firefox/6.0a1
Mozilla/5.0 (Windows NT 6.1; rv:5.0a2) Gecko/20110421 Firefox/5.0a2

Win XP:
Mozilla/5.0 (Windows NT 5.1; rv:5.0a2) Gecko/20110421 Firefox/5.0a2 
Mozilla/5.0 (Windows NT 5.1; rv:6.0a1) Gecko/20110421 Firefox/6.0a1 

Linux:
Mozilla/5.0 (X11; Linux i686; rv:6.0a1) Gecko/20110421 Firefox/6.0a1
Mozilla/5.0 (X11; Linux i686; rv:5.0a2) Gecko/20110421 Firefox/5.0a2

Mac 10.6:
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:5.0a2) Gecko/20110421 Firefox/5.0a2
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:6.0a1) Gecko/20110421 Firefox/6.0a1

Setting resolution to Verified

Note You need to log in before you can comment on or make changes to this bug.