Firefox 4 exits completly when minimize button is clicked [caused by Minimize To Tray Revived]

RESOLVED INVALID

Status

()

Firefox
Extension Compatibility
--
major
RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: Jared VanVolkenburg, Unassigned)

Tracking

4.0 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (X11; Linux i686; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (X11; Linux i686; rv:2.0) Gecko/20100101 Firefox/4.0

When the minimize button is clicked Firefox 4.0 released version, closes completely, regardless of how many windows or tabs are open at the time.  ALT-TAB does not show the firefox window as open, and Firefox must be relaunched.  When firefox opens, it opens as if freshly opened without the prompt to restore previously opened tabs.   This is not the correct or expected behavior. 

Reproducible: Always

Steps to Reproduce:
1. Launch Firefox 4.0
2. Open as many tabs or new windows as desired.
3. Minimize Firefox 4.0
4. ALT-TAB verify that there is no instance of Firefox windows open.
4. Relaunch Firefox 4.0
Actual Results:  
Firefox exits completely, including all windows.  On relaunch firefox opens as a new session, without launching previous tabs or windows.

Expected Results:  
Individual Firefox window  should have minimized, and be available when ALT-TAB.  Minimized window should be available to maximize.  

Firefox 4 Mozilla Firefox for Ubuntu canonical - 1.0 
Installed Version:  4.0+nobinonly-0ubuntu1 (natty)  
              --It is also the latest version available
Also Installed:
  firefox-globalmenu
      --Unity appmenu integration for Firefox
      --Version 4.0+nobinonly-0ubuntu1

  firefox-gnome-support
      --Safe and easy web browser from Mozilla - GNOME support
      --Version 4.0+nobinonly-0ubuntu1


Build Information:

about:buildconfig
Build platform
target
i686-pc-linux-gnu
Build tools
Compiler 	Version 	Compiler flags
gcc 	gcc version 4.5.2 (Ubuntu/Linaro 4.5.2-8ubuntu2) 	-Wall -W -Wno-unused -Wpointer-arith -Wcast-align -W -pedantic -Wno-long-long -g -fno-strict-aliasing -pthread -pipe -DNDEBUG -DTRIMMED -Os -freorder-blocks -fomit-frame-pointer -finline-limit=50
c++ 	gcc version 4.5.2 (Ubuntu/Linaro 4.5.2-8ubuntu2) 	-fno-rtti -fno-exceptions -Wall -Wpointer-arith -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wcast-align -Wno-invalid-offsetof -Wno-variadic-macros -Werror=return-type -pedantic -Wno-long-long -g -fno-strict-aliasing -fshort-wchar -pthread -pipe -DNDEBUG -DTRIMMED -Os -freorder-blocks -fomit-frame-pointer -finline-limit=50


Configure arguments

--build=i686-linux-gnu --prefix=/usr --localstatedir=/var --libexecdir=/usr/lib/firefox-4.0 --disable-maintainer-mode --disable-dependency-tracking --disable-silent-rules --srcdir=/build/buildd/firefox-4.0+nobinonly/build-tree/mozilla --disable-elf-dynstr-gc --disable-install-strip --disable-strip --disable-updater --enable-application=browser --enable-default-toolkit=cairo-gtk2 --enable-startup-notification --enable-pango --enable-svg --enable-mathml --enable-safe-browsing --with-distribution-id=com.ubuntu --without-system-jpeg --without-system-png --without-system-zlib --enable-chrome-format=omni --enable-optimize --enable-ipc --enable-tests --enable-mochitest --enable-ipdl-tests --disable-system-cairo --without-system-nspr --without-system-nss --disable-system-sqlite --disable-system-hunspell --enable-crashreporter --enable-official-branding --disable-gnomevfs --enable-gio --disable-debug --enable-extensions=default,globalmenu
(Reporter)

Updated

7 years ago
Summary: Firefox 4 exits completly when minimize button is pressed → Firefox 4 exits completly when minimize button is clicked
(Reporter)

Comment 1

7 years ago
Ubuntu Release 11.04
Kernel Linux 2.6.38-generic
Gnome 2.32.21
Unity Version: 3.8.6-0ubuntu1 (natty)
Does that also happen in Safe Mode (http://support.mozilla.com/en-US/kb/Safe+Mode) or with a fresh profile (http://support.mozilla.com/en-US/kb/Managing+profiles)?
(Reporter)

Comment 3

7 years ago
The minimize behavior functioned correctly in safe mode.  I removed the Minimize To Tray Revived addon ( https://addons.mozilla.org/en-us/firefox/addon/minimizetotray-revived/ ) and it seemed to fix the problem.  

I wanted to use that add-on because I often accidentally click the close ( x ) button and close firefox when I would actually like to minimize it.
(Reporter)

Comment 4

7 years ago
I reported this bug to the add-on developer.  However; if anyone has any more technical information they could add to it, please do so.

https://github.com/nmaier/mintrayr/issues/16
Thanks Jared. Lets hope it can get fixed in the add-on. Given that this is external code the bug is invalid.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Component: Menus → Extension Compatibility
QA Contact: menus → extension.compatibility
Resolution: --- → INVALID
Summary: Firefox 4 exits completly when minimize button is clicked → Firefox 4 exits completly when minimize button is clicked [caused by Minimize To Tray Revived]
Version: unspecified → 4.0 Branch
You need to log in before you can comment on or make changes to this bug.