Review actions don't get submitted when selecting "request more information"

VERIFIED FIXED in 6.0.6

Status

addons.mozilla.org Graveyard
Admin/Editor Tools
P1
major
VERIFIED FIXED
7 years ago
2 years ago

People

(Reporter: TheOne, Assigned: Andy McKay)

Tracking

({regression})

unspecified
6.0.6
regression

Details

(Whiteboard: [ReviewTeam], URL)

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
When I select "Request more information" as review action, insert the canned response and hit submit, I just get the same review page back with the activated "Request more information" action, the response is still in the textbox, but the review is not done actually.
There is no entry in the review history and the add-on is still in the queue.
Reproducible also on

https://addons.allizom.org/en-us/editors/review/738393
(Reporter)

Updated

7 years ago
Whiteboard: [required amo-editors]
(Reporter)

Updated

7 years ago
Summary: Review actions don't get submitted → Review actions don't get submitted when selecting "request more information"
I get sent back to the review list with the message ‘Review successfully processed,’ but the info request is not added to the review log. I can only presume that the message isn't sent either (I didn't get one when Andreas reviewed one of my add-ons on allizom).
(Reporter)

Comment 2

7 years ago
(In reply to comment #1)
> I get sent back to the review list with the message ‘Review successfully
> processed,’...

I don't get this message. I just get back to https://addons.mozilla.org/en-us/editors/review/688554#review-actions
Severity: normal → major
OS: Windows 7 → All
Priority: -- → P1
Hardware: x86 → All
Target Milestone: --- → 6.0.6
(Assignee)

Updated

7 years ago
Assignee: nobody → amckay

Comment 3

7 years ago
Created attachment 525693 [details]
screenshot

This used to work on allizom earlier.

Updated

7 years ago
Keywords: regression

Comment 4

7 years ago
I can reproduce this error.

In my error console, I see-

Error: uncaught exception: TypeError: commentHead.querySelector(".bz_comment_user a.email") is null

screencast: http://screencast.com/t/eIOPqkrAgKn
(Assignee)

Comment 5

7 years ago
https://github.com/jbalogh/zamboni/commit/9157bd375083f1628436e8f220a143f943cf5623
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Duplicate of this bug: 649947
Duplicate of this bug: 649947
According to comments on bug 649947, the email is being sent but the history item is not being added. Please verify this.

Comment 9

7 years ago
Editors can now request more information for add-ons awaiting review (full, lite or pending updates)

I checked that there is an email generated and that item history gets updated.


verified fixed @ https://addons-next.allizom.org/en-US/editors/review/763826?num=6
https://addons-next.allizom.org/en-US/editors/review/763840?num=1
https://addons-next.allizom.org/en-US/editors/review/763844?num=1
Status: RESOLVED → VERIFIED
Reclassifying editor bugs and changing to a new whiteboard flag. Spam, spam, spam, spam...
Whiteboard: [required amo-editors] → [ReviewTeam]
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.