Firefox Sync does not synchronize between computers

RESOLVED INVALID

Status

Cloud Services
Firefox Sync: Backend
--
major
RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: Anselmo Canfora, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0) Gecko/20100101 Firefox/4.0

I have two PCs turned on, with Firefox opened and Sync already set up, if I make a modification on bookmarks in one of them the modification does not show up in the other, even after half hour. I think there is the same issue with passwords (not tested)

Reproducible: Always

Steps to Reproduce:
1. set up Firefox Sync on two different PCs, and keep FF open in both of them
2. make a change on bookmarks in one PC
3. check the another PC to see if the change has been reflected on it
Actual Results:  
It does not work, period.

Expected Results:  
changes should show up istantly in the another machine (push data on change event in bookmarks, passwords and tabs)

Updated

7 years ago
Component: Bookmarks & History → Firefox Sync: Backend
Product: Firefox → Mozilla Services
QA Contact: bookmarks → sync-backend
Would you please attach a sync log from the problematic system.

1. Go to about:config in your browser.
2. Set services.sync.log.appender.debugLog.enabled to true
3. Restart your browser
4. Try logging into your Sync account again
5. If you get a failure, go to about:sync-log, save it to a file and attach it
to this bug.

Thanks!
(Reporter)

Comment 2

7 years ago
No error detected. Synchronization still not working. FF UI freezes during Sync merge.
Does about:sync-log show anything nonetheless (after you've done Kevin's steps 1 through 4)? If so, please attach it to this bug. Thanks!
Have you tried choosing "Sync Now" from the menu? Does that make a difference?

30 minutes is not long enough for a two-desktop sync to occur by default.
(Reporter)

Comment 5

7 years ago
If I do "sync now" all things get synchronized. But automatic syncing does not work. How much time it needs for a complete syncing?
(In reply to comment #5)
> If I do "sync now" all things get synchronized. But automatic syncing does not
> work. How much time it needs for a complete syncing?

If you have no mobile devices in your set of devices, a timed sync runs every hour.

If you have mobile devices, it runs every five minutes.

If you have two PCs, and you only waited 30 minutes, then it's unlikely that you waited long enough for a timed sync.

Sync does not currently use a push notifications model; see Bug 600429.
(Reporter)

Comment 7

7 years ago
Ok, now I understand. BTW Xmarks manage synchronization way better, I was used to get updates almost instantly with it. I think that at least for bookmarks and passwords FF should push updates as soon as they happen, after all javascript (is it sync still implemented in js?) for its nature can push updates asynchronously. This way perhaps you can avoid spikes and UI freeze during sync: I triggered a sync manually and it took over a minute to complete, during which FF UI was completely unresponsive.
(In reply to comment #7)
> I think that at least for bookmarks
> and passwords FF should push updates as soon as they happen, 

We're interested in reducing the time between syncs, but it's not as simple as you make it out to be.

> after all
> javascript (is it sync still implemented in js?) for its nature can push
> updates asynchronously.

I think you might be misunderstanding how all of this works.

> This way perhaps you can avoid spikes and UI freeze
> during sync: I triggered a sync manually and it took over a minute to complete,
> during which FF UI was completely unresponsive.

UI blocking is caused by synchronous operations, such as writing to the passwords store. Sync in Firefox 4 is much, much better about this than earlier versions, but there's a lot of work that needs to be done to the platform to allow us to make Sync entirely non-blocking. Even so, it shouldn't completely block the UI: perhaps you had another process running that had a lot of buffered disk IO, or have an add-on installed that was slowing things down?

Regardless, you should find that subsequent syncs are much faster: the less data exchanged, the less work Sync has to do.

Closing this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
(Reporter)

Comment 9

7 years ago
There were no other processes with "lot of buffered I/O", nor strange addons eating up cpu cycles and slowing things down. I have no doubt that your work is not simple as I can imagine (you are right, I did not have a look on Sync implementation, nor Weave code, so I have no idea on how it works), but I am a Google Browser Sync user first, and Xmarxs later, since 2006, and I can assure that they worked way smooth than Sync. Xmarks managed to work well even after the changes made in FF 3. I am sure that with time you will manage to overcome current shortcomings of Sync.
You need to log in before you can comment on or make changes to this bug.