Unable to continue typing once autocomplete displayed

VERIFIED DUPLICATE of bug 48619

Status

SeaMonkey
General
VERIFIED DUPLICATE of bug 48619
18 years ago
14 years ago

People

(Reporter: Becki Sanford, Assigned: asa)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.72 [en] (X11; U; Linux 2.4.0-test10 i686)
BuildID:    Mozilla 0.7 (Build ID 2001010517)

Once a partial match is made and the autocomplete popup is displayed, you cannot
continue to type the desired URL (i.e. one that is NOT in the autocomplete
list).

Reproducible: Always
Steps to Reproduce:
1.Open browser and go to http://www.petsmart.com
2.Now go to http://www.petco.com
3.Clear everything after "http://www." in the URL address
4.Attempt to go to http://www.pets.com

Actual Results:  Once the "p" is typed in the second URL, the autocomplete list
is displayed and further keyboard input is ignored.  The first entry in the list
is also automatically displayed in the URL field.

Expected Results:  The user should be able to continue typing WITHOUT having to
type superfast and WITHOUT having to click on the URL and fix it.

This is a general autocomplete problem since the same thing happens in email
when typing in email addresses.

Comment 1

18 years ago
Which window-manager are you using? This sounds like a problem with old sawfish,
it was fixed around version 0.30

Comment 2

18 years ago
the bug i have in mind is bug 48619. A workaround for old sawmill/sawfish is
described there.
(Reporter)

Comment 3

18 years ago
I've got sawfish-0.31.1-0_helix_2 RPM installed.

Comment 4

18 years ago
The bug was fixed in sawfish 0.33

A workaround in earlyer versions is to change the "Focus" setting for
"When does the mouse pointer affect the input focus:" to "enter-only".

Dup of 48619


*** This bug has been marked as a duplicate of 48619 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 5

18 years ago
VERIFIED DUpe
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.