Drag and drop items from History sidebar into Bookmarks Toolbar does not function

RESOLVED WORKSFORME

Status

()

Firefox
Bookmarks & History
RESOLVED WORKSFORME
7 years ago
4 years ago

People

(Reporter: George Carstoiu, Unassigned)

Tracking

4.0 Branch
Firefox 6
x86
Windows 7
Points:
---

Firefox Tracking Flags

(firefox6-)

Details

(Reporter)

Description

7 years ago
Mozilla/5.0 (Windows NT 6.1; rv:2.2a1pre) Gecko/20110412 Firefox/4.2a1pre

Drag and drop of an url from the history sidebar into the Bookmark Toolbar does not function after adding one url in the same way.

Reproducible: always

Steps to reproduce:
1. Display Bookmark toolbar
2. Open History Sidebar
3. Drag and drop one url from the sidebar to the Bookmark toolbar
4. Repeat step 3

Actual results:
 - links are no longer draggable

Expected results:
 - links can be dragged on the Bookmark toolbar
I just tried and it works pretty well. Try safe mode please to exclude add-ons: http://support.mozilla.com/kb/Safe+Mode
Otherwise I need better steps to reproduce.
(Reporter)

Comment 2

7 years ago
Mozilla/5.0 (Windows NT 6.1; rv:2.2a1pre) Gecko/20110412 Firefox/4.2a1pre

I just tried it again on a clean profile and on two other machines and I can easily reproduce the problem.

The drag and drop procedure works well with the first url, the issue being visible when trying with another url for the second time.
So, please make a FULL STEPS list specifying position of the bookmarks and everything on the new profile, since I really can't reproduce with the steps you gave.
Able to reproduce on Build identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.2a1pre) Gecko/20110412 Firefox/4.2a1pre

Steps used:
1.Show "Bookmarks Toolbar"
2.Press CTRL+H for the "History Sidebar" to appear
3.Drag a link from the "History Sidebar" and drop it to the "Bookmarks Toolbar"
4.Repeat Step 3
hm, I'm not sure why but I read that as Bookmarks Sidebar, sorry.
Can you confirm this is a regression in FF4 and works fine in FF3.6?
(Reporter)

Comment 6

7 years ago
Mozilla/5.0 (X11; Linux i686; rv:6.0a1) Gecko/20110413 Firefox/6.0a1

This is present ever since Firefox 3.6.16.

Also I observed that history remembers links as the user types them (for example google.com). By dropping the corresponding link in the bookmark toolbar a blank favicon is displayed without any text.
(Reporter)

Updated

7 years ago
tracking-firefox6: --- → ?
Target Milestone: --- → Firefox 6

Comment 7

7 years ago
Hey there. We're using this flag to track issues that are new to Firefox 6. For issues that are longstanding problems, contact mozilla.dev.firefox and see if you can find some help there. Thanks.
tracking-firefox6: ? → -
cannot reproduce
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.