(Tabs on Bottom) Add threshold for resizing tabs when mouse moves off toolbar

RESOLVED WONTFIX

Status

()

Firefox
Tabbed Browser
RESOLVED WONTFIX
7 years ago
7 years ago

People

(Reporter: ithinc, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:6.0a1) Gecko/20110413 Firefox/6.0a1
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:6.0a1) Gecko/20110413 Firefox/6.0a1

When "Tabs on Top" is not checked and mouse moves off the tab bar towards the content, resizing happens immediately.

Reproducible: Always

Steps to Reproduce:
1. Uncheck "Tabs on Top"
2. Open enough tabs and close them from a middle one
3. Move mouse to the content a little, for example 2px


Expected Results:  
It should resize when moving off is distant enough.
(Reporter)

Updated

7 years ago
Blocks: 465086
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Resizing happens immediately when mouse moves off tab bar → Add threshold for resizing tabs when mouse moves off toolbar

Comment 1

7 years ago
Tabs on Bottom is a non-default, legacy mode, and I don't think it is worth the effort to implement and maintain the implementation for a threshold.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX
Non-default, yes. Legacy, no. The option is exposed in the UI, intentionally so far.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---

Comment 3

7 years ago
Fair enough.
Status: REOPENED → NEW
Same applies to tab on top when moving the mouse out to the title bar.

Updated

7 years ago
Summary: Add threshold for resizing tabs when mouse moves off toolbar → (Tabs on Bottom) Add threshold for resizing tabs when mouse moves off toolbar

Updated

7 years ago
No longer blocks: 465086
Depends on: 465086

Comment 5

7 years ago
We want to change the behavior so that it always resizes immediately when
leaving the tab bar, so WONTFIX'ing this.

See bug 652735.
Status: NEW → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 6

7 years ago
The decision is rough.
(Reporter)

Comment 7

7 years ago
It's still valid a concern.
Status: RESOLVED → REOPENED
Keywords: uiwanted
Resolution: WONTFIX → ---
(Reporter)

Comment 8

7 years ago
Created attachment 536896 [details] [diff] [review]
patch
Attachment #536896 - Flags: ui-review?(limi)
Attachment #536896 - Flags: review?(dao)
Attachment #536896 - Flags: feedback?(fryn)
Comment on attachment 536896 [details] [diff] [review]
patch

I think we want bug 652735 instead.
Attachment #536896 - Flags: review?(dao)

Comment 10

7 years ago
Comment on attachment 536896 [details] [diff] [review]
patch

Like Dão said, I don't think we want this. See bug 652735 comments 1 and 2.
Attachment #536896 - Flags: ui-review?(limi)
Attachment #536896 - Flags: feedback?(fryn)
Attachment #536896 - Flags: feedback-

Comment 11

7 years ago
This is WONTFIX, because we won't take a patch for it.
Reasons were stated in bug 652735.
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago7 years ago
Keywords: uiwanted
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.