If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Mozbot incompatible with Bugzilla 4.0

RESOLVED DUPLICATE of bug 559721

Status

Webtools
Mozbot
--
major
RESOLVED DUPLICATE of bug 559721
7 years ago
6 years ago

People

(Reporter: Mike Wood, Unassigned)

Tracking

Trunk
PowerPC
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.16) Gecko/20110408 Gentoo Namoroka/3.6.16
Build Identifier: 

After upgrading Bugzilla to 4.0 mozbot logs an error when a bug is requested and no response is seen on the channel.

Reproducible: Always

Steps to Reproduce:
1. Upgrade/Install Bugzilla 4.0
2. Request bug information in IRC
3. Note the error in the log file
Actual Results:  
2011-04-13 19:18:22 UTC Told: #odamex-dev <HeX9109> bug 499
2011-04-13 19:18:22 UTC Module Bugzilla: spawned 7980 (wget --quiet --passive --user-agent="Mozilla/5.0 (compatible; mozbot)" --output-document=- http://odamex.net/bugs/show_bug.cgi?ctype=xml&excludefield=long_desc&excludefield=attachmentdata&excludefield=cc&id=499)
2011-04-13 19:18:23 UTC child 7980 completed URI
2011-04-13 19:18:23 UTC ERROR!!!
2011-04-13 19:18:23 UTC http://odamex.net/bugs/bugzilla.dtd:71: validity error : Redefinition of element delta_ts

<!ELEMENT delta_ts (#PCDATA)>
                             ^
http://odamex.net/bugs/bugzilla.dtd:85: parser error : AttValue: " or ' expected

          status CDATA #REQUIRED
          ^
http://odamex.net/bugs/bugzilla.dtd:85: parser error : Attribute default value declaration error

          status CDATA #REQUIRED
          ^
http://odamex.net/bugs/bugzilla.dtd:85: parser error : Space required after the attribute default value

          status CDATA #REQUIRED
          ^
http://odamex.net/bugs/bugzilla.dtd:85: parser error : Content error in the external subset

          status CDATA #REQUIRED
          ^

Expected Results:  
The bug information should be printed into the channel.
This is either the same as Bug 559721 or it is related to it, my hope is that fixing Bug 538428 should fix this and Bug 559721.
Depends on: 538428
(Reporter)

Comment 2

7 years ago
The patch attached to bug 538428 resolves this issue.

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 559721
You need to log in before you can comment on or make changes to this bug.