Wizard setup calls Service.startOver… which now tries to delete server entries

VERIFIED FIXED in mozilla5

Status

Cloud Services
Firefox Sync: Backend
VERIFIED FIXED
7 years ago
7 years ago

People

(Reporter: rnewman, Assigned: rnewman)

Tracking

unspecified
mozilla5
Points:
---
Bug Flags:
in-testsuite ?

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [verified in services])

Attachments

(1 attachment)

(Assignee)

Description

7 years ago
Probably shouldn't do that. :)
(Assignee)

Comment 1

7 years ago
Created attachment 525833 [details] [diff] [review]
v1

Fix is to not delete unless we have a clusterURL.

Test augmented to match.
Attachment #525833 - Flags: review?(philipp)
Comment on attachment 525833 [details] [diff] [review]
v1

>+    // Deletion doesn't make sense if we aren't set up yet!
>+    if (this.clusterURL != "") {

if (this.clusterURL) woulda worked too...

r=philikon
Attachment #525833 - Flags: review?(philipp) → review+
(Assignee)

Comment 3

7 years ago
Pushed:

https://hg.mozilla.org/services/services-central/rev/fad52be02cdc

STR for QA:

* Use a profile without Sync set up.
* Enable Sync logging.
* Open "Set Up Sync" dialog.
* Click "Connect".
* Click "Cancel". Observe no errors about malformed URIs in the log. Instead, you'll see a statement like this:

  Skipping client data removal: no cluster URL.
Flags: in-testsuite?
Whiteboard: [fixed in services]
verified in s-c builds of 1303795082

instead of malformed URI's error, now seeing:

1303835771043	Net.Resource	DEBUG	mesg: GET fail 304 https://setup.services.mozilla.com/d8ik
1303835771043	Net.Resource	DEBUG	GET fail 304 https://setup.services.mozilla.com/d8ik
1303835771738	Service.JPAKEClient	DEBUG	Aborting...
1303835771738	Service.JPAKEClient	DEBUG	Reporting failure to server.
1303835771738	Net.Resource	DEBUG	POST Length: 0
1303835771739	Service.Main	DEBUG	Skipping client data removal: no cluster URL.
1303835771739	Service.Main	INFO	Service reset.
1303835771740	Engine.Clients	DEBUG	Resetting clients last sync time
Whiteboard: [fixed in services] → [verified in services]
http://hg.mozilla.org/mozilla-central/rev/fad52be02cdc
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla6

Comment 6

7 years ago
Verified fix on m-c: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:6.0a1) Gecko/20110427 Firefox/6.0a1
Status: RESOLVED → VERIFIED
This was also landed on mozilla-beta (mozilla5) as part of bug 662181:

https://hg.mozilla.org/releases/mozilla-beta/rev/9d2108905529
https://hg.mozilla.org/releases/mozilla-beta/rev/065b5f7e37c1
Target Milestone: mozilla6 → mozilla5
You need to log in before you can comment on or make changes to this bug.