Add Marble Run to Web O Wonder

VERIFIED FIXED in 2.2

Status

VERIFIED FIXED
8 years ago
8 years ago

People

(Reporter: lmesa, Unassigned)

Tracking

unspecified
x86
Mac OS X
Dependency tree / graph

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
Created attachment 525790 [details]
Marble Run Screenshot

Guys, I've added what I can. Main thing that's missing is the screencast.

Authors
* First Name, Last Name,  homepage url

David Strauß http://stravid.com
Mathias Paumgarten http://mathias-paumgarten.com
Eberhard Gräther http://egraether.com
Matthias Paul Hempt http://hempt.at
Nicola Lieser http://nicolalieser.com

Demo
* Title - Marble Run
* Slug - marblerun
* Description -
** "The winner of _Mozilla GameOn Challenge_ (https://gaming.mozillalabs.com/games/winners) builds a gorgeous HTML5 game without plugins.


* Category - HTML5, Design, Video, or WebGL
**Category to me is HTML5
* Tag list (like Geolocation, WebGL, Audio, etc)
**Paul, what should be added? David suggested 
"PrototypeJS (http://www.prototypejs.org/)
cookies-js-helper (https://github.com/tdd/cookies-js-helper)
box2d-js (https://github.com/jwagner/box2d2-js)"
* Source url (github link)
**https://github.com/MathiasPaumgarten/marblerun


Media
* Screenshot (checked into demo repo)
** also attached to bug
* Screencast (put on videos.m.o)
**still needs to be done
* Documentary (optional) 
**Will not be added

Comment 1

8 years ago
(In reply to comment #0)
> Description

We don't have support for HTML in this field. Plain text only.

We can do:
The winner of Mozilla GameOn Challenge builds a gorgeous HTML5 game
without plugins.

> * Tag list (like Geolocation, WebGL, Audio, etc)
> **Paul, what should be added? David suggested 
> "PrototypeJS (http://www.prototypejs.org/)
> cookies-js-helper (https://github.com/tdd/cookies-js-helper)
> box2d-js (https://github.com/jwagner/box2d2-js)"

These aren't tags, are they? Does info like belong in the github README, wiki, forums, etc.

Also - I forgot to ask, does this demo work under Mobile? I don't think so, and should be flagged Desktop only. Right?
(Reporter)

Comment 2

8 years ago
Your description works for me!
They aren't tags, but maybe Paul can suggest what else can we put there. 
And yes, desktop only demo.
(Reporter)

Updated

8 years ago
Blocks: 600772
No longer blocks: 628811
(Reporter)

Updated

8 years ago
Duplicate of this bug: 651058
(Reporter)

Comment 4

8 years ago
Per 651058

Category - HTML5
Tag list - HTML5, Canvas

I will add the screencast today.
(Reporter)

Comment 5

8 years ago
I have the screencasts but cannot connect to https://videos.mozilla.org/manage/mozhacks to add them. I'm going to try and get desktop support to help me figure out why.

Comment 6

8 years ago
Done in https://github.com/mozilla/webowonder/commit/9fa31e64db1411839397b3cea09279540538b190

Please change the status to RESOLVED:FIXED once the videos are uploaded.
(Reporter)

Comment 7

8 years ago
(In reply to comment #6)
> Done in
> https://github.com/mozilla/webowonder/commit/9fa31e64db1411839397b3cea09279540538b190
> 
> Please change the status to RESOLVED:FIXED once the videos are uploaded.

IT and desktop haven't been able to help me fix the upload issues I have--I don't want to be the blocker here--I can upload the videos to my People account--ozten, from there do you think you could upload the videos yourself?

Or what are our other options?

Comment 8

8 years ago
I have the same problem with the Webdav, I don't think Ozten can do anything.
(Reporter)

Comment 9

8 years ago
Just updated the screencasts to 

http://videos-cdn.mozilla.org/serv/mozhacks/demos/screencasts/marblerun/

Should be good to go.
I wanted to double check.

This demo is 100% client side, so we don't have any scalability concerns when we launch it, right?
(In reply to comment #10)
> I wanted to double check.
> 
> This demo is 100% client side, so we don't have any scalability concerns when
> we launch it, right?

What about https://bugzilla.mozilla.org/show_bug.cgi?id=651191
(Reporter)

Updated

8 years ago
Depends on: 651191

Updated

8 years ago
Depends on: 651873
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
verified fixed https://demos.mozilla.org
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.