If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Design and Firefox-ification of Join Mozilla supporter card and letter -

RESOLVED FIXED

Status

Marketing
Design
RESOLVED FIXED
7 years ago
6 years ago

People

(Reporter: chelsea, Assigned: Rhonda Spencer)

Tracking

Details

Attachments

(8 attachments)

(Reporter)

Description

7 years ago
Hey Tara,
We've decided to produce and ship out physical membership cards for Join Mozilla. Merchandise Mania will produce the cards in the UK. They will send them attached to a welcome letter.

Card (dimensions 3.370 inches by 2.125 inches, full colour)
What we're looking for is something that is graphic and very light on text (aside from the supporter's name) so that it can be used for all the current and future Join Mozilla locales. We're pretty limited with Mozilla graphic elements we can so I'd love to chat with you about ideas for it. 

Letter 
I'd like to so something a little more interesting than just welcome copy on letterhead. I'm getting the layout requirements from Merchandise Mania so we know where the card and supporter address should go and how that might shape our ideas on what the letter should look and sound like.

In terms of timing, I'd don't want to rush this as these cards need to be something people are going to want to keep (hopefully forever and ever). We're going to push Join Mozilla out of beta in mid-May, so if we could have design locked down by April 28 or so, I'd be a happy camper. 

I'll set up a time to chat about this on Zimbra.
(Reporter)

Updated

7 years ago
Summary: Design Join Mozilla membership card and letter → Design Join Mozilla supporter card and letter
(Reporter)

Comment 1

7 years ago
Created attachment 526276 [details]
AI template for supporters card
(Reporter)

Comment 2

7 years ago
I have the artwork specs for each item as follows:

The backing card: 99 x 210mm, with a 3mm bleed, in PDF with outlines on all texts and fonts and editable.

Supporters card: Template attached, please add a 3mm bleed, in vectorised EPS.

Comment 3

7 years ago
thanks Chelsea!  per our conversation, here's a quick recap and next steps:

CARD: 

* Would be great to make this more than a static card but something that has other benefits, a unique function...  adding a QR code that points to an interesting landing page would be cool.  Lets brainstorm on what that might be (without increasing scope by too much). Otherwise, we'll keep things simple and have that as a "nice to have" for Phase II.

* Front: will have the supporter's name and date they joined.  I'll check the template to make sure they've shown us where this goes.  Design will be relatively simple and based on the standard Join Mozilla design library - reddish hues, "tequila sunrise" as Lee calls it, the crowd scene, heart-banner, ec.  and the "mozilla" wordmark. 

* Back will have similar basic graphics but with a tag line.  Chelsea is to share some suggestions for what the tagline will be.  

* Overall, design will be simple, but we'll pepper in some goodness so it's not boring.

LETTERHEAD:

* A simple letterhead design that incorporates a few splashes of the Join Mozilla graphics.  I think having the crowd scene across the bottom would be great.  Something that jazzes up the page a bit, but leaves it mostly white and clean. 

-----------------

Will ask Lee to help us whip this up since he's familiar with the graphics and can probably do this relatively quickly.  Initial timing:  2 weeks.

Comment 4

7 years ago
Hey Chelsea.  I opened the .ai file (it may have lost some data in the process since I was using an older version of illustrator)  but all I see is basically a rounded rectangle in the shape of the card -- no indication of where the name and other information would be printed.  Could you please ask for this from the vendor?  We need that before we can start designing.  Thanks.
(Reporter)

Comment 5

7 years ago
Hey Tara, 
Will do!
Cheers, 
C
(Reporter)

Comment 6

7 years ago
Hey Tara, 
I got some additional details from the production company.

Size of card: 86 x 54 mm

The names will be printed as per attached picture. There is no restriction on the size or positioning of the names but they have to be printed horizontally in black. They are digitally printed so your design can be any way you like!
(Reporter)

Comment 7

7 years ago
Created attachment 526978 [details]
Printed name example for supporters card

Comment 8

7 years ago
Hi Chelsea,
Can you clarify if you want these designs to mimic the existing art on the Join site?
https://donate.mozilla.org/page/contribute/protect-the-web

 - or will this new iteration possibly replace the 'virtual card' on the site. Either way, is it of interest to keep these consistent?

Comment 9

7 years ago
Also, for the automated printed names by the production company, are we restricted to certain fonts, or can we specify?
(Reporter)

Comment 10

7 years ago
Hey Lee, 
I think we want to keep them consistent or at least related in some way. I'll follow up with the production company about the fonts.

Cheers, 
C
(Reporter)

Comment 11

7 years ago
Waiting for a final okay from the production company, but I have a tentative okay that we can use whatever font we want. It just has to be black ink.
(Reporter)

Comment 12

7 years ago
Okay, here's the official word from the supplier:

For individual printed names – The standard font is Arial, we can however send a specific font required to the factory and they can use this, they do have a number of fonts already (please see attached). They cannot print in anything other than English fonts (i.e. Arabic, Chinese is not available). 

A general point to follow is to print in a fairly boxy thick font as this reproduces much better than anything to thin or delicate (image attached of standard font).

Names must not be within 5 mm of the edge of the card

Lettering can be from font size 12 – 16. (max size 15mm)

Lettering needs to be black on white background.
(Reporter)

Comment 13

7 years ago
Created attachment 527525 [details]
Supporter name factory font list

Updated

7 years ago
Assignee: tshahian → ltom

Updated

7 years ago
Blocks: 652975
(Reporter)

Updated

7 years ago
Summary: Design Join Mozilla supporter card and letter → Design and Firefox-ification of Join Mozilla supporter card and letter -

Comment 14

7 years ago
Hey Lee.  I'd like to pass this off to Rhonda.  Could you please either post or send me the link to the latest you have on this card?  She can finish it off.  Thanks.

Updated

7 years ago
Assignee: ltom → rspencer

Comment 15

7 years ago
Hey all. Whipping this up now.

For the letter, what is the copy?

Comment 16

7 years ago
er...  wrong bug.

BUT!

Some .ai files with assets can be found here to keep the look consistent: https://bugzilla.mozilla.org/show_bug.cgi?id=652584#c13

Enjoy!

Comment 17

7 years ago
Chatted with Rhonda today.  She's going to jump on this asap.  Should be pretty quick given that we have the new theme and other assets to leverage from Sean/Lee.
(Reporter)

Comment 18

7 years ago
Awesome. I will get working on the letter copy then. Will hopefully have it EOD tomorrow. Thanks!
(Reporter)

Comment 19

7 years ago
Hey ladies.
Here's the letter copy. I've asked leadership if we need to have legal text on the card, so I'll update if we hear back. Hopefully we can just add something at the bottom that says "This card grants you the title of Mozilla supporter. It does not give you voting rights, thicker hair or the ability to talk to animals."

Until we know, copy below:

Dear %%firstname%%,

Congratulations! You're now a card-carrying Mozilla supporter! You're a part of a growing community of people who want to make the web a better place for the billions of people who use it. You are helping preserve the world's largest public resource: the Web, and you now have the card to prove it.

Show your card to friends and family. See if you can find another Mozilla supporter with an earlier join date. If you have a smartphone, scan the QR code on the back of the card every few months for a fun surprise. 

If you have any questions about your card please get in touch with us at askjoin@mozilla.org. Keep it near and dear to you. 

Thanks again for supporting Mozilla, and for showing your love of the Web.

Chelsea Novak
Join Mozilla
(Assignee)

Comment 20

7 years ago
hey guys--
Im coming in on this just now, so I just wanted to confirm what I am designing here:
One Supporters card 
(printed plastic card 86 x 54mm) single side design, which includes space for a name the printer will print in black Ariel font. The design is carried from Sean's design of the virtual card.

Regarding comment 4--I have the same file and all I see is a rectangle as well. If I keep the name in the same place Sean has it in his file thats fine, but it may not be fine with the printer. Can we find out how much freedom we have in terms of where the printed name goes on the card layout?

One Letter that holds the card (I am assuming?)
Size of letter? A4? A5? Does the printer have a specific place that they would like the card to rest in this letter? Is the card going to be stuck inside the letter somewhere with fugitive glue or something like that?

If you can get me this info I can start getting these together. Let me know if you have any questions.
:)
--rhonda
(Reporter)

Comment 21

7 years ago
Hey Rhonda, 
Supporter's card:
It can actually be a two-sided card. I think the QR code should go on the back for example.

I'll follow up with MM to see about how much freedom we have in terms of layout. The card is going to be attached to the letter and I've asked for more detail on where it will be placed. 

I'll update as soon as I know.
(Reporter)

Comment 22

7 years ago
Update!

The names don’t have to be on a white background and can be anywhere on the card! The size of the backing card is 210 x 100mm mailer card (250gsm) printed full colour on one side and 1 colour on the other - see pictures attached. 

Please remember that the membership cards are full colour both sides. We can even add a Firefox hologram (another image attached)? 
 
There are no restrictions as to where we put the card on the backing card. But the attached example is one idea.

Everything is completely bespoke so we can really have whatever we want!
(Reporter)

Comment 23

7 years ago
Created attachment 530003 [details]
Hologram examples
(Reporter)

Comment 24

7 years ago
Created attachment 530004 [details]
Card placement example
(Reporter)

Comment 25

7 years ago
Created attachment 530005 [details]
Card placement example 2
(Assignee)

Comment 26

7 years ago
Hi Chelsea--
Thanks for sending the attachments. I still have a few questions about the card backing and letter. Also-- just for clairity, can we refer to the Backing card and the Plastic card as such so I can be clear on what card we are referring to when we discuss? It can get confusing otherwise. :)

Here are the items I have questions about:

Letter: Size? A4, A5 or standard US 8.5 x 11? How many colors can the letter be printed in? CMYK? Is this letter going to be folded to fit into an envelope? If so, will this letter be intended to fold around the Backing Card?

Backing card: Physical size? Do I understand correctly that it is printed 4 color over 1 color back side? What do you want this card to say/content/copy? Do you have the QR code for me to place on this Backing card or does the printer do this? In the attachment examples above, the Backing Card has the users info, QR code, legal etc. Are you going to supply that to me so I can put it in the layout on the one color side on the back?

Plastic card: Do I understand that it is printed in 4 colors both sides? One side will have the design that Sean mocked up for the digital card and one side will contain possibly a hologram?

Its important that I get all these details before I can finish up.

Thanks and let me know if any of this is not clear.

--rhonda
(Reporter)

Comment 27

7 years ago
Hey Rhonda, 

Awesome questions. Answers in-line

Just so that we have the right terms down there is a supporters card (made of plastic, hereafter called plastic card) and it is sent attached to a letter (hereafter called backing letter)
 
> Letter: Size? A4, A5 or standard US 8.5 x 11? 
It's being produced in the UK so we can go with A4 or a custom size as you see in the example. It will be sent in an A4 envelope, but that's the only restriction.

>How many colors can the letter be printed in? CMYK? 
CMYK

>Is this letter going to be folded to fit into an envelope? If so, will this letter be intended to fold around the Backing Card?

Yes. To be folded into an A4 envelope.

> Backing card: Physical size? Do I understand correctly that it is printed 4
> color over 1 color back side?

Just in case there's confusion here. The backing card is the letter and the plastic card is attached to it. There are only two components. 


>What do you want this card to say/content/copy?

The copy for the backing card/letter is in comment 19. In terms of the content for the plastic card, I'd like it to have as little copy as possible, just be visual so that we can avoid having to localize it. 


> Do you have the QR code for me to place on this Backing card or does the
> printer do this? 

I don't have one yet. I will get one for you shortly. Tara do you know how to go ahead getting a QR code generated?

>In the attachment examples above, the Backing Card has the users info, QR code, legal etc. Are you going to supply that to me so I can put it in the layout on the one color side on the back?

The plastic card will have the supporters name and their join date on the front. I will get you a QR code. We've determine that no legal is required for the plastic card itself. 

The backing letter will just be copy and design.
 
> Plastic card: Do I understand that it is printed in 4 colors both sides? One side will have the design that Sean mocked up for the digital card and one side will contain possibly a hologram?

It will be 4 colour on both sides. The front will be based on Sean's design, have the supporter's name and join date and possibly a hologram. The back will be the QR code.

Let me know if there are any additional questions about this or if you want me to napkin sketch something out for you .
(Assignee)

Comment 28

7 years ago
Hey Chelsea--
OK! Now I understand. Sorry I was thinking that there were 3 pieces, but it makes alot more sense now.

I'll get to work on these-- thanks!

:)
--rhonda
(Assignee)

Comment 29

7 years ago
Hey Chelsea--
I have the Backing card front and back, and also the plastic card front ready for first proof here:

http://www.intothefuzz.com/rhonda/Join_mozilla_card/card_backing_back.pdf
http://www.intothefuzz.com/rhonda/Join_mozilla_card/card_backing_front.pdf
http://www.intothefuzz.com/rhonda/Join_mozilla_card/join_moz_plastic_card.pdf


Notes: I didnt know what should go on the back of the plastic card so I didnt mock it up for now. The back of the Backing card is in black ink, and I indicated where the QR code might go. The front of the Backing card has plenty of space if you wanted to add some copy there.

Let me know what you think.

Thanks--
rhonda
(Reporter)

Comment 30

7 years ago
Hey Rhonda, 

This is starting to look great. In all the descriptions I think I didn't state that we want the QR code to go on the back of the plastic card, not on the letter itself. Do you think we should add some copy to go beside it to tell people what to do with it? Something like "Scan this code with your smartphone for more Mozilla fun."

Cheers, 
C
(Assignee)

Comment 31

7 years ago
Hey Chelsea--
Oh, ok no worries, we'll put it on the back of the plastic card then. And yes I would add a blurb so people know what to do with it, even though it is stated in the letter.
:)--rhonda
(Reporter)

Comment 32

7 years ago
Hey Rhonda, 
How about this for now:

Scan this quick response code with your smartphone and get connected to more Mozilla fun. Your smartphone will need a barcode scanning application for the code to work. 

Caitlin - who should I talk to about getting the actual code produced?

Comment 33

7 years ago
It's a can of corn! I go here and just plug in the URL and it generates the image for me: http://qrcode.kaywa.com/

Comment 34

7 years ago
Just a thought:  eventually, we might want to look into doing custom QR code designs:  http://dessertcontent.com/wp-content/uploads/2011/04/Disney-QR-Code.jpg

Comment 35

7 years ago
Like our Facebook profile pic? http://www.facebook.com/firefoxformobile
(Assignee)

Comment 36

7 years ago
Hey guys--
I put a placeholder for the QR code on the back of the card along with the blurb of copy about what to do with it. Let me know what you think.
--rhonda

http://www.intothefuzz.com/rhonda/Join_mozilla_card/join_moz_plastic_card_back.pdf
(Reporter)

Comment 37

7 years ago
I like it! 

I just got word from the production facility that we can have a hologram added to the card at no additional cost (magic!). I think a hologram of the Firefox logo would be the best idea. 

Rhonda, do you think this would work best on the front or the back of the plastic card?
(Reporter)

Comment 38

7 years ago
Caitlin/Tara - I really like the custom code idea. Would I get it from kaywa as well or did you have it designed by someone else?
(Assignee)

Comment 39

7 years ago
Hey Caitlin--
I think the hologram would work best on the back of the card with the code--you could put it in the location that the logo is on the back now. 
--rhonda
(Reporter)

Comment 40

7 years ago
Hey Rhonda, 
Let's do it on the back then, unless Tara has any objections.

Thanks!
Chelsea

Comment 41

7 years ago
Let me check with Slater first re: hologram :)  

We'd need to see a proof I'd think.

Uncharted brand territory!
(Reporter)

Comment 42

7 years ago
Sounds good to me. I'll let you know when they can send us proofs (assuming we get the okay from Slater).

Comment 43

7 years ago
"Help us Firefox, you're our only hope...help us Firefox, you're our only hope"

I'm intrigued by but not totally sold on the hologram. Would want to see a printed proof (or have Sean see it) before committing. Who would be creating such a thing?
(Reporter)

Comment 44

7 years ago
Merchandise Mania (or one of their suppliers) is creating it. I've asked them about the viability of a sample. Will let you know once I hear back. 

"May the open web be with you, always"

Comment 45

7 years ago
I know getting samples isn't always efficient if we're on a time crunch.  But getting samples is *really* important... especially with something like this that's supposed to be a a cool membership card.  We should ensure highest of quality possible.... and sometimes you'd be shocked at what comes through production!  So, if possible, we should definitely get a physical sample to inspect.
(Reporter)

Comment 46

7 years ago
No objection to getting a sample on my end. Just finding out the process of getting one :)

Comment 47

7 years ago
Got it :)
(Reporter)

Comment 48

7 years ago
Update from Merchandise Mania. Samples are not a problem.

Rhonda, can you mock up two designs for the back of the card? One with space for a hologram and one like you had before with a printed Firefox logo?

Thanks!
C

Comment 49

7 years ago
Hey guys, Rhonda is PTO today and will be back on Monday.
(Assignee)

Comment 50

6 years ago
Hey guys--
the layout of the hologram version of the back of the plastic card is here:
http://www.intothefuzz.com/rhonda/Join_mozilla_card/join_moz_plastic_card_back2.pdf

The sizing of the QR code and hologram is only approximate, as we would need to get the exact dimensions from the printer before we could lay it out with any accuracy, so this is for proofing only.

Also, in looking at the hologram examples, it looks as though the holograms rely on the use of a solid black image that reverses out of the hologram sticker, hence the use of the black logo mark. 

Thanks!
--rhonda
(Reporter)

Comment 51

6 years ago
Hey Rhonda, 

I'll get exact dimensions then. Be in touch.
(Reporter)

Comment 52

6 years ago
Okay, 16mm x 16mm are the dimensions. :)

Also, do you have a copy of the Firefox logo that is just the outline without the continents? Sean said that he would like to use that one for the hologram. Let me know if you need me to get it for you.

Thanks and let me know if you have any questions.
(Assignee)

Comment 53

6 years ago
Hey Chelsea--
There is one that I have but Im not sure its the one Sean wants to use, so to be sure I have the right one, can you send that over to me in Illustrator 4? Thanks!
--rhonda
(Reporter)

Comment 54

6 years ago
Created attachment 533403 [details]
Firefox outline
(Reporter)

Comment 55

6 years ago
Attached above!

Comment 56

6 years ago
Rhonda, let us know if you need anything else here to move forward and wrap up.  I wasn't able to open the eps (opened as empty) but hopefully you had no troubles.
(Assignee)

Comment 57

6 years ago
Hi Tara--
Actually I cant open the file either--it needs to be saved down to Illustrator 4 for me to open.
If someone can resave and resend I'll get right on it. Thanks! :)
--rhonda
(Reporter)

Comment 58

6 years ago
Hey Tara, Rhonda, 

I got the file from Sean, but can't open it either (don't have the software). Sean can you send the file to Tara/Rhonda?
(Assignee)

Comment 59

6 years ago
Hey Chelsea and Tara--
I emailed a friend who has Illustrator 5 to see if she can open and resave to Illustrator 4 so I can open. I hope to hear from her today -- stay tuned. Sorry for the delay.
--rhonda
(Assignee)

Comment 60

6 years ago
Hi Chelsea--
I replaced the hologram with the right logo and made it 16mm x 16mm. Take a look and let me know what you think.
:)
--rhonda

http://www.intothefuzz.com/rhonda/Join_mozilla_card/join_moz_plastic_card_back2.pdf

Comment 61

6 years ago
sorry for the delay on the illustration. glad you got it in a readable format. looks good!
(Reporter)

Comment 62

6 years ago
Hey Rhonda, 

Looking good. Are we ready for sample production?

Cheers, 
C
(Assignee)

Comment 63

6 years ago
Hey Chelsea--
Sure. Couple of questions:
1. Is Merchandise Mania printing only a sample of the hologram or are they doing a sample of the plastic card, backing, AND the hologram?

2. I will need printing specs from the printer of the hologram (we already know the size but I need to know if I just submit a black logo to them and they do the rest?) They should know the answers to give me on that.

3. Finally, I will need to know the printing specs for both cards (they gave us a dieline for the plastic card but I need to know bleed sizes, and what file type they prefer for printing).

Then we'll be ready to hand off for print.
:)
--rhonda
(Reporter)

Comment 64

6 years ago
Hi Rhonda, 
I am asking them to do a sample of the entire package. I'll get you the answers on the spec for the hologram and the bleed sizes/file type for printing. 

I'll be in touch!
Cheers, 
C
(Reporter)

Comment 65

6 years ago
Hey Rhonda, 

Here's the scoop from MM. 

The specs for the plastic card are attached. For the backing card they need 3mm.

All artwork needs to be in vectorized EPS.

Thanks!
Chelsea
(Reporter)

Comment 66

6 years ago
Created attachment 535337 [details]
Card spec
(Assignee)

Comment 67

6 years ago
Hi Chelsea--
The files below are good to go for the printer. They are saved as PDF, but can be opened in Illustrator as vector files.

For the plastic card:
BACK:
I deleted the hologram and QR code that we were using for proofing, so that all that is on the back of the plastic card is the paragraph about how to scan the QR code. Once the hologram is printed and the QR code sample is printed on the back of the card it will look right with the type at the bottom.

FRONT:
I deleted the fake name that we used there for proofing so that there is a blank space for the printers to print a name from their data base there.

let me know if the printer needs anything else for the sample printing.

Thanks!
--rhonda

http://www.intothefuzz.com/rhonda/Join_mozilla_card/files_for_printer.zip
(Assignee)

Comment 68

6 years ago
...and here is the hologram file:

http://www.intothefuzz.com/rhonda/Join_mozilla_card/FF_hologram.eps
(Reporter)

Comment 69

6 years ago
Thank you so much Rhonda. Passing these along to MM for sample production.

Cheers, 
c

Comment 70

6 years ago
Per Chelsea, we're ready to close this.  Thanks all.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.