Last Comment Bug 649819 - Remove JS_BeginJSONParse, JS_ConsumeJSONText, JS_FinishJSONParse
: Remove JS_BeginJSONParse, JS_ConsumeJSONText, JS_FinishJSONParse
Status: RESOLVED FIXED
fixed-in-tracemonkey
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla6
Assigned To: Jeff Walden [:Waldo] (remove +bmo to email)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-13 14:55 PDT by Jeff Walden [:Waldo] (remove +bmo to email)
Modified: 2011-04-26 15:16 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (2.13 KB, patch)
2011-04-13 14:55 PDT, Jeff Walden [:Waldo] (remove +bmo to email)
brendan: review+
Details | Diff | Review

Description Jeff Walden [:Waldo] (remove +bmo to email) 2011-04-13 14:55:36 PDT
Created attachment 525831 [details] [diff] [review]
Patch

We have JS_ParseJSON and JS_ParseJSONWithReviver which are much simpler to use.  Also, at the moment the old APIs use the old JSON parser almost by necessity, and making them use the new parser is somewhat hard.  (Nothing in Mozilla uses the old APIs, only the new ones, so web pages/etc. only ever see behavior according to the new parser -- *not* multiple different parsers.)

This patch just removes the API entry points.  It doesn't remove the old parser yet because it's still possible there might end up some strong reason to revert (and we couldn't just make the necessary change to the new parser).  That can be for later once we're comfortable with the new parser, don't see too much reason to rush it (I'm the only one having to deal with an extra 600 lines of code in json.cpp these days, really).
Comment 1 Jeff Walden [:Waldo] (remove +bmo to email) 2011-04-14 12:58:25 PDT
http://hg.mozilla.org/tracemonkey/rev/f7eaddcc2abf
Comment 2 Chris Leary [:cdleary] (not checking bugmail) 2011-04-26 15:16:53 PDT
http://hg.mozilla.org/mozilla-central/rev/f7eaddcc2abf

Note You need to log in before you can comment on or make changes to this bug.