[ERROR] Internal error dispatching command “goto-url-external”.

RESOLVED INVALID

Status

Other Applications
ChatZilla
--
major
RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: Jim Jeffery not reading bug-mail 1/2/11, Assigned: Robert Ginda)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

I'm getting the following errors when I click on a link in Chatzilla running on xulrunner:


 [ERROR] Internal error dispatching command “goto-url-external”.
		[ERROR] NS_ERROR_FILE_NOT_FOUND: Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIExternalProtocolService.loadUrl] @ <chrome://chatzilla/content/commands.js> 2255

I just updated to latest version of Chatzilla and it didn't help. 

Seems to have regressed between these checkins on m-c trunk nightly/hourly builds:
20110411193144 598855101f12 bad
20110411183209 bc035b7a2aab good

patches checked in in the regression range:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=bc035b7a2aab&tochange=598855101f12

Nothing stands out other than the name change from Minefiled to Nightly maybe - thought don't know what that would matter.
Keywords: regression

Comment 1

7 years ago
(In reply to comment #0)
> I'm getting the following errors when I click on a link in Chatzilla running on
> xulrunner:
> 
> 
>  [ERROR] Internal error dispatching command “goto-url-external”.
>         [ERROR] NS_ERROR_FILE_NOT_FOUND: Component returned failure code:
> 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIExternalProtocolService.loadUrl] @
> <chrome://chatzilla/content/commands.js> 2255
> 
> I just updated to latest version of Chatzilla and it didn't help. 
> 
> Seems to have regressed between these checkins on m-c trunk nightly/hourly
> builds:
> 20110411193144 598855101f12 bad
> 20110411183209 bc035b7a2aab good
> 
> patches checked in in the regression range:
> http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=bc035b7a2aab&tochange=598855101f12
> 
> Nothing stands out other than the name change from Minefiled to Nightly maybe -
> thought don't know what that would matter.

I suspect the binary name of your browser changed, and so there's a file not found error because /path/to/whatever/dir/minefield  no longer works. Can you doublecheck that? :-)

Comment 2

7 years ago
(In reply to comment #1)
> the binary name of your browser

Eh, mean the name of the binary, obviously...
Yes, Minefield has been replaced by 'nightly' with a path:

J:\Program Files (x86)\Nightly as I noted in my original post.  I still have the Minefield directory it seems.  I will just delete it and see what happens.
Didn't help..

Comment 5

7 years ago
This error is from non-ChatZilla code and I'm almost certain it means your default browser association is invalid - for the reasons Gijs mentioned, i.e. the old Firefox executable has gone and you've not corrected the association.

If the version of Firefox that you want to be your default claims it is already your default, it is buggy and you should file a Firefox bug on that. If it does not think it is the default (which would be correct), set it as the default.
OK, I have no idea how or where to fix that.

Comment 7

7 years ago
You use Firefox's options to set it as the default browser.

This bug is not a valid bug, however, because it has nothing whatsoever to do with ChatZilla and is almost certainly caused by a system configuration issue. If you can prove otherwise, please reopen.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
thanks so much for your non-support.  I have already checked the Options-applications and set irc  to the path to Nightly and it does not work. 

I asked for help in Developers and Firefox and was told to file a chatzilla bug...

go figure -- no one want to take ownership of the problem.
Status: RESOLVED → UNCONFIRMED
Ever confirmed: false
Resolution: INVALID → ---

Comment 9

7 years ago
#developers and #firefox were wrong to tell you to file a bug here; the error is being reported from non-ChatZilla code and it well beyond our control. There is no bug in ChatZilla as far as the information you've provided goes.

The association you should be checking is Firefox's 'default browser' status, which you can find under Advanced > General at the bottom. If Firefox thinks it is the default browser but links still won't open, try setting something else (another installation of Firefox will do) as the default and then setting the correct Firefox again. If that still doesn't work, you really should be seeking help in #firefox because it is their issue, not ChatZilla's.

Comment 10

7 years ago
You checked what Options application?  And why are you setting the irc handler?  It's the system http handler that is the problem.
In J:\Users\Username\AppData\Roaming\ChatZilla\Profiles\wdl0j7np.default

I had to edit:  mimeTypes.rdf 

In several places there was the 'Minefield' in the patch, replaced with 'Nightly' (without single quote) and all is well again.  

So, to me had nothing to do with system settings, did not matter that Nightly/Minefiled/firefox was 'default' browser or not.  Since I had to edit it in a Chatzilla mimeType file, its neither system, nor Firefox's problem. 

Marking Fixed so others can find it if need be.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → FIXED

Comment 12

7 years ago
That is not a ChatZilla file and is created and modified by core FireFox code. Bug is invalid.
Resolution: FIXED → INVALID

Comment 13

7 years ago
More specifically, it's handled by xulrunner and there is no way to modify it from chatzilla.  I wonder how it got set in the first place as it should be using the system setting instead.
You need to log in before you can comment on or make changes to this bug.