Firefox button color is not changed (remains orange) if Private Browsing mode is invoked via the -private command line parameter

RESOLVED DUPLICATE of bug 645995

Status

()

RESOLVED DUPLICATE of bug 645995
8 years ago
4 years ago

People

(Reporter: srinath, Unassigned)

Tracking

Trunk
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; InfoPath.2; FDM)
Build Identifier: 

After tweaking nightly to launch in private browsing mode through quick launch area of Win 7, Nightly opens in private browsing mode BUT the Nightly (Firefox) menu button remains orange. It should turn Purple

Reproducible: Always

Steps to Reproduce:
1. Install the latest build of firefox nightly edition (http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/firefox-6.0a1.en-US.win32.installer.exe -- built on 13 April 2011)
2. Pin the browser to the taskbar (Win 7)
3. Tweak the properties of nightly to change the target being run to "C:\Program Files\Nightly\firefox.exe" -private
4. Launch Nightly now
Actual Results:  
The window opens in private browsing mode
The Nightly menu button remains Orange

Expected Results:  
The Nightly menu button should turn to Purple as Purple is the menu colour for private browsing mode

Comment 1

8 years ago
This affects 4.0 as well and affects any instance of Firefox started with the -private switch.
Status: UNCONFIRMED → NEW
Component: Menus → Private Browsing
Ever confirmed: true
QA Contact: menus → private.browsing
Summary: Configuring to open firefox thru quicklaunch shortcut launches firefox in private browsing but with firefox menu button in orange colour → Firefox button color is not changed (remains orange) if Private Browsing mode is invoked via the -private command line parameter
Version: unspecified → Trunk

Comment 2

8 years ago
Okay, I see now.  This is by design.  See bug 588655 comment 17.  Launching Firefox with the -private switch puts Firefox into "permanent" private browsing mode, and apparently, it was decided that permanent mode should not carry outward such indicators.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID

Comment 3

8 years ago
s/outward such/such outward/  :P

I guess it makes sense, as a way to let people discreetly using PB.
Agreed on. Sounds reasonable.
Status: RESOLVED → VERIFIED

Updated

5 years ago
Duplicate of this bug: 944647

Updated

4 years ago
Status: VERIFIED → RESOLVED
Last Resolved: 8 years ago4 years ago
Resolution: INVALID → DUPLICATE
Duplicate of bug: 645995
You need to log in before you can comment on or make changes to this bug.