Closed Bug 649938 Opened 12 years ago Closed 12 years ago

compare-locales doesn't support having a compare.dirs under another

Categories

(Mozilla Localizations :: Infrastructure, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: glandium, Assigned: glandium)

References

Details

Attachments

(1 file)

Attached patch PatchSplinter Review
See bug 561032 comment 21 and bug 561032 comment 22.

The patch I'm attaching solves the problem in a generic way, though it does so only for compare-locales but not for compare-dirs.
Attachment #525960 - Flags: review?(l10n)
Can you explain why this is fixing which problem how? Might be just that I'm suffering from jetlag, but this doesn't build a picture for me right now.
The problem is that when compare-locales enumerates the l10n directory for "browser", it lists "browser/branding/official", because there is no separation between what used is in browser/locales/en-US and what is in browser/branding/official/locales/en-US in mozilla-central.
So, when comparing the l10n directory with the mozilla-central directory, compare-locales ends up saying browser/branding/official files were removed.

What the patch does is that when enumerating the l10n directories, it filters out the other l10n directories that are under it, e.g. it filters out browser/branding/official when enumerating browser.

Not sure I'm being very clear.
Comment on attachment 525960 [details] [diff] [review]
Patch

r=me, thanks, pushed, too.

http://hg.mozilla.org/l10n/compare-locales/pushloghtml?changeset=6e71300f03de

I pushed that on top of what I think would be the least-risk update to RELEASE_AUTOMATION, and then merged to the latest.
Attachment #525960 - Flags: review?(l10n) → review+
-> FIXED.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Assignee: nobody → mh+mozilla
You need to log in before you can comment on or make changes to this bug.