Closed Bug 649940 Opened 11 years ago Closed 3 years ago

Opening the preferences dialog with the default settings active always creates the "Downloads" folder

Categories

(Toolkit :: Downloads API, defect)

All
Windows XP
defect
Not set
normal

Tracking

()

VERIFIED WONTFIX

People

(Reporter: Virtual, Unassigned)

References

Details

(Keywords: nightly-community)

User-Agent:       Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:6.0a1) Gecko/20110413 Firefox/6.0a1
Build Identifier: 

Like Henrik Skupin [:whimboo] said "Opening the preferences dialog with a clean profile immediately creates the downloads folder, and not after selecting another
folder"

Reproducible: Always
No longer blocks: 474718
Depends on: 474718
I wanted to create this bug today but seems like you was faster.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Opening the preferences dialog creates the "Downloads" folder → Opening the preferences dialog with the default settings active always creates the "Downloads" folder
Version: unspecified → 1.9.2 Branch
This only affects Windows 2000/XP. As mentioned in the other bug, there aren't really any good ways to fix this. I don't think we will before we get around to dropping support for those operating systems (which will likely be in a long time).
(In reply to :Gavin Sharp (use gavin@gavinsharp.com for email) from comment #2)
> This only affects Windows 2000/XP.

Actually Win-2K only problem?

Creation is perhaps done by following code.
> http://mxr.mozilla.org/mozilla-central/source/toolkit/components/downloads/nsDownloadManager.cpp#1367
> 1367 // This could be the first time we are creating the downloads folder in My
> 1368 // Documents, so make sure it exists.
> 1369     bool exists;
> 1370     rv = downloadDir->Exists(&exists);
> 1371     NS_ENSURE_SUCCESS(rv, rv);
> 1372     if (!exists) {
> 1373       rv = downloadDir->Create(nsIFile::DIRECTORY_TYPE, 0755);
> 1374       NS_ENSURE_SUCCESS(rv, rv);
> 1375     }
And I could observe creation of "download" directory in Fx 17 on Win-XP by simply opening download-directory picker dialog while browser.download.folderList=2 is already set and existent/writable directory is set in browser.download.dir.

I used Fx en-US on Japanese MS Win. Because Japanese MS Win uses "...\My Documents\ダウンロード"(in Japanese) for download directory, and because Fx en-US creates "...\My Documents\download", I can know excess "download" creation by Fx at a glance.
Please note that some peoples can't afford to creation of "...\My Documents\download" by Fx even though he deleted needless "...\My Documents\download" for him.

Note:
I could find following only by search for "->create" with "download" in filename.
> Found 2 matching lines
> /mozilla/toolkit/components/downloads/nsDownloadManager.cpp
> line 1373 -- rv = downloadDir->Create(nsIFile::DIRECTORY_TYPE, 0755);
> line 1481 -- rv = customDirectory->Create(nsIFile::DIRECTORY_TYPE, 0755);
So, I think above code is creator of "download" directory.
Version: 1.9.2 Branch → Trunk
Blocks: 702382
No longer blocks: 702382
Duplicate of this bug: 702382
Has Regression Range: --- → irrelevant
Has STR: --- → yes
Version: Trunk → unspecified

I'm closing this bug as WONTFIX, as Firefox has ended support for Windows XP and Vista[1]

[1] = https://support.mozilla.org/en-US/kb/end-support-windows-xp-and-vista

Status: NEW → RESOLVED
Closed: 3 years ago
OS: All → Windows XP
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.