Last Comment Bug 649965 - elfhack fails to build with gcc 4.6 lto
: elfhack fails to build with gcc 4.6 lto
Status: VERIFIED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: All Linux
: -- normal (vote)
: mozilla7
Assigned To: Mike Hommey [:glandium]
:
Mentors:
: 647458 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-14 05:07 PDT by Mike Hommey [:glandium]
Modified: 2012-06-21 21:50 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Remove inlines on Elf_*::swap functions (3.41 KB, patch)
2011-04-14 05:07 PDT, Mike Hommey [:glandium]
taras.mozilla: review+
Details | Diff | Splinter Review

Description Mike Hommey [:glandium] 2011-04-14 05:07:24 PDT
Created attachment 525977 [details] [diff] [review]
Remove inlines on Elf_*::swap functions

As reported on gcc bugzilla: http://gcc.gnu.org/bugzilla/show_bug.cgi?id=45375#c65

In function `serialize':
/var/tmp/mozilla-central/build/unix/elfhack/elfxx.h:239: undefined reference to
`void Elf_Ehdr_Traits::swap<big_endian, Elf64_Ehdr,
serializable<Elf_Ehdr_Traits> >(serializable<Elf_Ehdr_Traits>&, Elf64_Ehdr&)'
/var/tmp/mozilla-central/build/unix/elfhack/elfxx.h:228: undefined reference to
`void Elf_Ehdr_Traits::swap<big_endian, Elf32_Ehdr,
serializable<Elf_Ehdr_Traits> >(serializable<Elf_Ehdr_Traits>&, Elf32_Ehdr&)'
collect2: ld returned 1 exit status
Comment 2 Simona B [:simonab ] 2011-08-26 05:44:59 PDT
Mozilla/5.0 (Windows NT 5.1; rv:7.0) Gecko/20100101 Firefox/7.0

I visually inspected the code changes. Marking as Verified Fixed as per bug 659997 - Comment 7.
Comment 3 Matthew Gregan [:kinetik] 2012-06-21 21:50:23 PDT
*** Bug 647458 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.