[traceback] OverflowError: mktime argument out of range

VERIFIED DUPLICATE of bug 645850

Status

Input
General
--
major
VERIFIED DUPLICATE of bug 645850
7 years ago
6 years ago

People

(Reporter: stephend, Unassigned)

Tracking

Bug Flags:
in-testsuite ?

Details

(URL)

(Reporter)

Description

7 years ago
Traceback on http://input.stage.mozilla.com//en-US/beta/search?product=firefox&version=4.0b12&date_start=&date_end=01%2F01%2F2900:

Traceback (most recent call last):

 File "/data/www/input.stage.mozilla.com/reporter/vendor/packages/Django/django/core/handlers/base.py", line 100, in get_response
   response = callback(request, *callback_args, **callback_kwargs)

 File "/data/www/input.stage.mozilla.com/reporter/vendor/packages/Django/django/utils/decorators.py", line 76, in _wrapped_view
   response = view_func(request, *args, **kwargs)

 File "/data/www/input.stage.mozilla.com/reporter/apps/input/decorators.py", line 43, in cached_view
   return f(request, *args, **kwargs)

 File "/data/www/input.stage.mozilla.com/reporter/apps/search/views.py", line 209, in index
   request, meta=meta)

 File "/data/www/input.stage.mozilla.com/reporter/apps/search/views.py", line 58, in _get_results
   opinions = c.query(query, **search_opts)

 File "/data/www/input.stage.mozilla.com/reporter/apps/search/client.py", line 179, in query
   (includes, ranges, metas) = extract_filters(kwargs)

 File "/data/www/input.stage.mozilla.com/reporter/apps/search/client.py", line 81, in extract_filters
   end = time_as_int(end_date)

 File "/data/www/input.stage.mozilla.com/reporter/apps/search/client.py", line 93, in time_as_int
   return int(timegm(t) if utc else time.mktime(t))

OverflowError: mktime argument out of range
Flags: in-testsuite?

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 645850

Updated

7 years ago
Status: RESOLVED → VERIFIED
(Assignee)

Updated

7 years ago
Component: Input → General
Product: Webtools → Input
Adding back the in-testsuite flag that was mistakenly removed.
Flags: in-testsuite?
You need to log in before you can comment on or make changes to this bug.