Firefox 4 regression with Flash-blocking add-ons

RESOLVED INVALID

Status

()

Firefox
Extension Compatibility
RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: Rod Spade, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0) Gecko/20100101 Firefox/4.0

On some pages on finance.yahoo.com, embedded flash video begins playing automatically, even if Flashblock or Stop Autoplay is installed.  This did not happen in Firefox 3.6.

When I experimented with this problem, sometimes the Flash was blocked correctly - but if I held Shift and hit Reload to clear the cache, the video always started to play.

I recently experienced the issue on these pages:
http://finance.yahoo.com/blogs/breakout/oil-producers-not-crude-oil-where-investing-calamos-20110414-052332-167.html
http://finance.yahoo.com/blogs/daily-ticker/not-only-peter-lynch-wrong-stocks-general-bad-20110413-050251-817.html

It appears that the embedded player is typically one of these:
http://d.yimg.com/nl/techticker/breakout/player.swf
http://d.yimg.com/nl/techticker/site/player.swf


Reproducible: Always

Steps to Reproduce:
1.  Install either Flashblock or Stop Autoplay.
2.  Go to affected web page.
3.  If embedded flash video does not start automatically, hit Shift-Reload.
Actual Results:  
Video plays.

Expected Results:  
Embedded Flash should be blocked by add-on.
I am not sure if it is firefox's or addon's bug but I confirm that with flashblock at windows, firefox 4 after a simple reload plays the flash at the above pages without block it first.
Please report issues with extensions to the extension author.
(There is no native blocking of flash in Firefox)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

7 years ago
I will report this to the extensions' authors.  However, since the problem occurs with 2 different extensions, both of which worked fine in Firefox 3.6, it may be related to an issue with Firefox 4 rather than the add-ons.
You need to log in before you can comment on or make changes to this bug.