Closed Bug 650110 Opened 9 years ago Closed 9 years ago

Update SUTAgentAndroid in m-c tree to 1.01

Categories

(Testing :: General, defect)

x86
Windows 7
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: bmoss, Assigned: bmoss)

References

Details

Attachments

(4 files, 5 obsolete files)

Attached file patch file for v 1.01 (obsolete) —
Various fixes and enhancements which will bring the agent code in the tree upto version 1.01.
Comment on attachment 526100 [details]
patch file for v 1.01

Here's the patch
Attachment #526100 - Flags: review?(ctalbert)
Assignee: nobody → bmoss
Status: NEW → ASSIGNED
Attachment #526109 - Flags: review?(ctalbert)
Attachment #526100 - Attachment is obsolete: true
Attachment #526100 - Flags: review?(ctalbert)
Attachment #526111 - Flags: review?(ctalbert)
Attachment #526127 - Flags: review?(ctalbert)
Attached patch fixed add watcher diff (obsolete) — Splinter Review
Attachment #526127 - Attachment is obsolete: true
Attachment #526127 - Flags: review?(ctalbert)
Attachment #526129 - Attachment is obsolete: true
Attachment #526139 - Flags: review?(ctalbert)
Attachment #526139 - Attachment is obsolete: true
Attachment #526139 - Flags: review?(ctalbert)
Attachment #526146 - Flags: review?(ctalbert)
Attached patch Whitespace refactor for the rest (obsolete) — Splinter Review
Attachment #526158 - Flags: review?(ctalbert)
Comment on attachment 526109 [details] [diff] [review]
Whitespace refactor for 1.01

Ah, that makefile change accidentally crept in here, that's why it fails to apply.  No worries.  I can take care of that before checking it in.
Attachment #526109 - Flags: review?(ctalbert) → review+
Attachment #526158 - Attachment is obsolete: true
Attachment #526158 - Flags: review?(ctalbert)
Attachment #526161 - Flags: review?(ctalbert)
Attachment #526111 - Flags: review?(ctalbert) → review+
Comment on attachment 526146 [details] [diff] [review]
adds watcher, ffxcp, and fencp

There's a typo in the FfxCP makefile.  It says FfxCP.java when it should be ffxcp.java.  I'll fix that at checkin time.

It seems like there should be a better way to share code between the FenCP and FfxCP instances without duplicating the code.  At least in make, we could put them in one directory with two targets, but I'm not sure exactly how to handle that on the java side.  It seems java needs the package <foo> statement at the top.  I'm generally against interpolating files, but would it be better to interpolate so that you don't have to duplicate so much code?  

If we end up fixing bugs in this code, then it'd probably be good to refactor it so that the code is shared.  But for now, to get this into the tree and building, it's sufficient to keep things as they are.
Attachment #526146 - Flags: review?(ctalbert) → review+
Attachment #526161 - Flags: review?(ctalbert) → review+
Pushing all these patches to try as a final sanity check cause I don't want to back them out if they go sideways in automation.
Try run was green, landing on M-C:
* http://hg.mozilla.org/mozilla-central/rev/85f57f532181 - main agent
* http://hg.mozilla.org/mozilla-central/rev/bffad5e71e5c - agent white space 
* http://hg.mozilla.org/mozilla-central/rev/a9e746c648ab - fencp, ffxcp, watcher
* http://hg.mozilla.org/mozilla-central/rev/eb1b83360605 - fencp, ffxcp, watcher whitespace
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Duplicate of this bug: 612461
You need to log in before you can comment on or make changes to this bug.