Duplicate f1 icon after update

RESOLVED WONTFIX

Status

Mozilla Labs
F1
RESOLVED WONTFIX
7 years ago
7 years ago

People

(Reporter: fabrice, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Created attachment 526143 [details]
screenshot

f1 updated itself today and this added a second f1 icon in my urlbar.

I'm running a nightly build.
Any errors in the error console? Do both icons work?
(Reporter)

Comment 2

7 years ago
Both icons worked, and I did not see anything in the console. Restarting firefox fixed the issue.
From IRC earlier today:

<sheppy> Also apparently whenever I hit any arrow key. That's annoying.
<KWierso> sheppy: you and mcmanus are both seeing this, but I'm not
<sheppy> KWierso: It only seems to happen in some windows.
<sheppy> I have one window where F1 behaves itself, and one where it doesn't.
<sheppy> Interestingly, the window where it's misbehaving, I have two "f1" icons in my URL bar.
<KWierso> restart Firefox, maybe something doesn't like the recent restartless version of f1?
<sheppy> Been using that for like three weeks, no problems until yesterday.
<KWierso> hrm, it just updated today for me
<jhammel> sheppy: funny, you'd think one of them would be f2
<sheppy> jhammel: ideally


CCing Sheppy

This might've been from F1 being made restartless (it activated the restartless version right away, before deactivating the non-restartless one)?
(In reply to comment #3)
> This might've been from F1 being made restartless (it activated the restartless
> version right away, before deactivating the non-restartless one)?

In that case that seems like an AddonManager bug. Previously restartful and now restartless addons should require a restart before becoming active.

Do you remember from which to which F1 version you upgraded?
I updated TO 0.8.3. No clue what it was on before. But I never saw this happen, personally. Maybe it did occur and I just wasn't paying any attention to it and then I restarted Firefox and it went away. 

For me, I just spontaneously had a new tab open up explaining the new restartless version of F1 mid-session. (That page DID mention that F1 is now restartless, but this first update still required an update, though. No clue if it followed through with that or not.)
I updated to the restartless f1 weeks ago. It worked fine for ages, just started misbehaving the other day.

Also, I see the same thing... the f1 "Hey, it's all new" window keeps opening up over and over again, at random. Its very strange.
not reproducible in next-gen addon, closing
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.