Favicon.ico pulled from first certificate domain when using SNI

RESOLVED WORKSFORME

Status

()

Firefox
Address Bar
RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: Andrew Davies, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0

https://changewebsite.co.uk has an SSL certificate and uses SNI.

When viewing the domain in a browser that doesn't support SNI, the SSL certificate for the domain http://tls.webepos.eu/ is shown.

When viewing https://changewebsite.co.uk/favicon.ico the correct favicon is shown. When viewing https://changewebsite.co.uk/ the favicon for http://tls.webepos.eu/ is shown in the location bar.

changewebsite.co.uk has never had the favicon from tls.webepos.eu
This is a bug that in Firefox 4.0, as it works fine in Opera, Safari & IE9.

Reproducible: Always

Steps to Reproduce:
1. visit https://changewebsite.co.uk and look at the favicon
2. visit https://changewebsite.co.uk/favicon.ico
3. visit https://tls.webepos.eu/favicon.ico


Actual Results:  
Notice how the favicon for tls.webepos.eu is being shown on changewebsite.co.uk, due to using SNI

Expected Results:  
it should show https://changewebsite.co.uk/favicon.ico
(Reporter)

Comment 1

7 years ago
The Location bar icon and Tab icons are effected by this. Both show the same icon.

Comment 2

7 years ago
I am not seeing the issue. Can you attach a screenshot showing the issue?

Does the issue still occur if you start Firefox in Safe Mode? http://support.mozilla.com/en-US/kb/Safe+Mode

How about with a new, empty profile? http://support.mozilla.com/en-US/kb/Basic+Troubleshooting#Make_a_new_profile
(Reporter)

Comment 3

7 years ago
(In reply to comment #2)
> I am not seeing the issue. Can you attach a screenshot showing the issue?
> 
> Does the issue still occur if you start Firefox in Safe Mode?
> http://support.mozilla.com/en-US/kb/Safe+Mode
> 
> How about with a new, empty profile?
> http://support.mozilla.com/en-US/kb/Basic+Troubleshooting#Make_a_new_profile

I am not seeing the issue today (after a machine reboot).

Maybe a test for someone with a (clean) browser that has not seen the above sites would be:

1. visit https://tls.webepos.eu and look at the favicon
2. visit https://changewebsite.co.uk and look at the favicon

If you are seeing the "book" favicon on step 2, then this is a non-issue that just effected me for some reason.

Comment 4

7 years ago
I am seeing the "book" favicon in step 2. I will close the bug and if it comes back, feel free to post and we can re-open.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.