Ogg files do not play correctly. They glitch at the end.

VERIFIED DUPLICATE of bug 665344

Status

()

VERIFIED DUPLICATE of bug 665344
8 years ago
8 years ago

People

(Reporter: mozilla2, Unassigned)

Tracking

({regression})

2.0 Branch
x86
All
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox5-)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0) Gecko/20100101 Firefox/4.0

Click the URL above in FF4, try FF3 or Chrome. In FF3 and Chrome the sound plays correctly. In FF4 on both OSX and Windows XP there is a glitch at the end of the sound.

Reproducible: Always

Steps to Reproduce:
1. Run FF4
2. Click this url http://powpow.googlecode.com/hg/assets/fire.ogg

Actual Results:  
The sound playback has a glitch at the end

Expected Results:  
The sound should have no glitch at the end.

Comment 1

8 years ago
Regression window(cached m-c hourly):
Works:
http://hg.mozilla.org/mozilla-central/rev/aaa780337c05
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b13pre) Gecko/20110228 Firefox/4.0b13pre ID:20110301170838
Broken:
http://hg.mozilla.org/mozilla-central/rev/635bb4ffe6ad
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b13pre) Gecko/20110301 Firefox/4.0b13pre ID:20110301174408
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=aaa780337c05&tochange=635bb4ffe6ad
Suspected:
635bb4ffe6ad	Matthew Gregan — Bug 636894 - Revert bug 634787's change to AUDIO_DURATION_MS to work around a regression in MozAudioAvailable event delivery. r=roc a=roc
Blocks: 636894
Status: UNCONFIRMED → NEW
tracking-firefox5: --- → ?
Component: General → Video/Audio
Ever confirmed: true
Keywords: regression
Product: Firefox → Core
QA Contact: general → video.audio
Version: unspecified → 2.0 Branch

Comment 2

8 years ago
ogg use isn't widespread enough and this issue isn't bad enough to require it resolved before FF5 ship. tracking-
tracking-firefox5: ? → -

Comment 3

8 years ago
Does the issue occur in WebM files as well? If that patch is common code shared by all backends then it probably does. Meaning all our audio (Wav, WebM and Ogg) would show it.

Comment 4

8 years ago
first regression:
In local build:
build from ee00364d3092 : fails
build from 5212ab4ae808 : works

Triggered by
ee00364d3092	Chris Double — Bug 607838 - Allow audio drains to be interrupted - r=cpearce a=blocking2.0:final
Blocks: 607838
Thanks for reducing this, it sounds like a duplicate of bug 665344.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 665344
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.