Window controls go black when switching themes in Windows 7

RESOLVED DUPLICATE of bug 621857

Status

()

Firefox
General
--
trivial
RESOLVED DUPLICATE of bug 621857
7 years ago
4 years ago

People

(Reporter: Björn Persson, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0) Gecko/20100101 Firefox/4.0

When switching theme in Windows 7 and then back the window controls (minimize, maximize/restore, and close) become a black area.

Reproducible: Always

Steps to Reproduce:
1. Switch from Aero theme to Windows Classic theme
2. Switch back to previous Aero theme
3.
Actual Results:  
In some Firefox windows the window controls are just black and don't work. In other windows the controls are shown with the wrong theme, i.e. don't 'fit'.

Expected Results:  
Shown the controls with design for current theme.

I'm running Windows 7 (x86) on a computer where drivers only exist for XP and Vista, and I'm (mainly) using drivers distributed from manufacturer och Microsoft, i.e. might be driver problem and not Firefox problem.

I have an integrated Intel graphics card.

Comment 1

7 years ago
This is probably a dupe after bug 621857.
Whiteboard: dupeme
(Reporter)

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 621857

Updated

4 years ago
Whiteboard: dupeme
You need to log in before you can comment on or make changes to this bug.