Sites page has version --all-- listed for both desktop and mobile products

VERIFIED FIXED in 3.4

Status

P1
normal
VERIFIED FIXED
8 years ago
8 years ago

People

(Reporter: davehunt, Assigned: davedash)

Tracking

({regression})

Trunk
regression

Details

(Whiteboard: [fromAutomation], URL)

Steps to reproduce:

1. Visit http://input.stage.mozilla.com/en-US/beta/sites

Expected:

Only valid versions are listed for each product. Latest version is selected by default.

Actual:

In addition to the valid versions, there is also an '--all--' option for both desktop and mobile products. This is selected by default, and does not show any results.
Flags: in-testsuite+
Priority: -- → P1
Target Milestone: --- → 3.4
It would appear the reason for this and bug 650917 is probably the same.


Maybe the removal of sites-specific VERSIONS [1] had this effect (during cleanup / PEP8 formatting)?


[1] https://github.com/fwenzel/reporter/commit/d67b1bc811da630fb1456f6e65a788002f2293dd
That seems legitmate - I didn't realize it was different from search.forms.

I can put it back in.
Assignee: nobody → dd
http://github.com/fwenzel/reporter/commit/db3b6b4
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Verified the latest version of the product is selected by default. Note: the beta channel no longer exists so automation will need to be updated to reflect this change.
Status: RESOLVED → VERIFIED
> Note: the beta channel no longer exists so automation will need to be updated to reflect this change.

Actually, it does exist; it just hasn't started up yet. So, that might be something to take note when we do get the 1st beta channel builds sometime around May 17th.
Good point :) thanks. There's just a lot of churn hitting our automation and its making the kittens cry (in good ways).

Note:
Chuck Norris doesn't seem to be effected at all.
Automated tests are also now passing.
Component: Input → General
Product: Webtools → Input
You need to log in before you can comment on or make changes to this bug.