This URL makes Firefox 4.0 crash

RESOLVED WORKSFORME

Status

Plugins Graveyard
VLC (VideoLAN)
RESOLVED WORKSFORME
7 years ago
2 years ago

People

(Reporter: Hervé Cauwelier, Unassigned)

Tracking

({crash, stackwanted})

Details

(URL)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:2.0) Gecko/20110321 Firefox/4.0
Build Identifier: Mozilla/5.0 (X11; Linux x86_64; rv:2.0) Gecko/20110321 Firefox/4.0

I use Flashblock when I click to load the applet, Firefox crashes.

I wouldn't worry about the usual Flash **** if Firefox was not supposed to crash because of a plugin anymore.

Reproducible: Always

Steps to Reproduce:
1. Go to the URL
2. Start the applet if Flash is blocked

Actual Results:  
Firefox crashes instantly

Expected Results:  
I don't think I saw such a crasher since plugins run in a different process.

This is the branded Firefox on Archlinux x86_64.
(Reporter)

Comment 1

7 years ago
This is printed on the console when the page is loaded:

*** NSPlugin Viewer  *** WARNING: unhandled variable 18 (<unknown variable>) in NPN_GetValue()

This is printed when Firefox crashes:

firefox: symbol lookup error: /usr/lib/mozilla/plugins/libvlcplugin.so: undefined symbol: NPP_Initialize

Strange, it's a Flash video.

Comment 2

7 years ago
Have you submitted any crash reports? If so then look in about:crashes and post the id:s/links here.

Also try to run in Safe Mode and see if that makes any difference:
https://support.mozilla.com/en-US/kb/Safe+Mode

Peeking into the page source the video seems to be a mix of Flash and Silverlight and I've no idea why the vlc plugin gets involved.

Do you still get crashes if you disable the vlc plugin in the Add-ons Manager?

Comment 3

7 years ago
https://developer.mozilla.org/en/How_to_get_a_stacktrace_for_a_bug_report#Linux

this is probably a bug in vlc (which is probably pretending to be flash player -- see about:plugins)
Component: General → VLC (VideoLAN)
Keywords: crash, stackwanted
Product: Firefox → Plugins
QA Contact: general → videolan-vlc
(Reporter)

Comment 4

7 years ago
I'm afraid the page changed, so I cannot reproduce the bug. I have to close it. Sorry for the noise.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

2 years ago
Product: Plugins → Plugins Graveyard
You need to log in before you can comment on or make changes to this bug.