Allow user to browse with caret, if a pref is set

VERIFIED DUPLICATE of bug 49508

Status

()

Core
Keyboard: Navigation
--
enhancement
VERIFIED DUPLICATE of bug 49508
18 years ago
18 years ago

People

(Reporter: Aaron Leventhal, Assigned: Aaron Leventhal)

Tracking

({access})

Trunk
x86
All
access
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

18 years ago
This enhancement will allow users of screen readers and other accessibility
tools to browse Mozilla as if it's a read-only editor. 

Rather than arrow keys scrolling the page up, down, left and right, they move a
visible caret. Shifted movement keys highlight a selection. This way selection
can be done without the mouse. This involves changes to nsGlobalWindow.cpp and
htmlBindings.xml.

The visible caret is set to "readonly" so that it's gray and doesn't blink. This
indicates to the user that no data entry is allowed. This involves changes in
nsCaret.cpp.

If the user presses tab or shift-tab, the focus is moved relative to the
position of the caret. In addition, whenever the focus moves, the caret is
placed at the start of the focus. When the user moves the caret over a link, the
link is focused. This involves changes in nsEventStateManager.cpp.

I'm 90% done with this coding. All that remains is to ensure the readonly state
is properly maintained when focus changes.
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Keywords: access

Comment 1

18 years ago
Aaron, question: Did you file a bug about improving keyboard navigation support?
I can't find a bug about that issue. I'm almost sure there is one already! As I
see this I think, maybe Aaron, just asking!

/HJ

Comment 2

18 years ago
b.t.w. try to use preferences without your mouse!
(Assignee)

Comment 3

18 years ago

*** This bug has been marked as a duplicate of 49508 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 4

18 years ago
vrfy dup
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.