After boosting on desktop, badges and challenges should be updated without a page reload

VERIFIED FIXED in 1.2

Status

Websites
spark.mozilla.org
VERIFIED FIXED
7 years ago
7 years ago

People

(Reporter: Franck Lecollinet, Assigned: Franck Lecollinet)

Tracking

unspecified

Details

(Assignee)

Description

7 years ago
As reported by TBG:

"I created a new account and immediately boosted, which should have earned me the "On Location" and "Parent Trap" badges, but when I successfully exited the overlay and landed on the page, I still had the "You haven't earned any badges" message and those challenges hadn't cleared."
(Assignee)

Updated

7 years ago
Assignee: nobody → franck.bugzilla
Target Milestone: --- → 1.2
(Assignee)

Updated

7 years ago
Duplicate of this bug: 650528
(Assignee)

Comment 2

7 years ago
Badge and challenge sections are now auto-updated after each Boost step completion on the desktop website.

Fixed in commit:
https://github.com/mozilla/spark/commit/9672a9d5fd829bd695744541a165287605159a80
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
verified fixed https://spark.allizom.org/en-US/
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.