Closed Bug 650490 Opened 13 years ago Closed 13 years ago

SVG <img> tag with zoom: scaling is broken.

Categories

(Core :: SVG, defect)

x86_64
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 600207

People

(Reporter: jmckesson, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: 

If you go to the given website and zoom in, the SVG images (using the <img> tag) do not scale well. They scale like raster images, when they should be re-rasterized, just like they would be if they were in <object> tags.

Reproducible: Always

Steps to Reproduce:
1. Go to website
2. See that the SVG looks OK.
3. Zoom in.
4. See that the SVG image scales like a raster image.
Component: General → SVG
QA Contact: general → general
Version: unspecified → Trunk
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
(To explain the duplicate-marking -- so, even though the image here isn't tiled, we likely hit the image-tiling codepath due to a marginal rounding issue, with values like in bug 600207 comment 7.  Basically, when we scale some images up, we're left with a tiny fractional-pixel amount of extra space at one of the image's edges, which makes us trigger the image-tiling codepath, which sadly causes pixellation right now).
You need to log in before you can comment on or make changes to this bug.