Closed Bug 650671 Opened 9 years ago Closed 9 years ago

typeof a OBJECT elements returns "function" and not "object"

Categories

(Core :: DOM: Core & HTML, defect)

x86_64
Linux
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 268945

People

(Reporter: mozilla, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (X11; Linux x86_64; rv:2.0) Gecko/20100101 Firefox/4.0

This bug is similar to this bug https://bugzilla.mozilla.org/show_bug.cgi?id=421102 but occurs on the OBJECT element.

Reproducible: Always

Steps to Reproduce:
1. In a HTML document, add a OBJECT element including ex a svg.
2. With javascript; get the OBJECT element and assign it to a variable.
3. Do a typeof on the variable holding the OBJECT element.
Actual Results:  
The typeof returns "function"

Expected Results:  
typeof should return "object"

All other "modern" browsers than FireFox returns "object". 
Example can be seen here: 
http://files.trygve-lie.com/tests/object_typeof/

Screenshot of FireFox vs "other browsers" of the above example:
http://files.trygve-lie.com/bugs/ff_object_typeof.png
Component: General → DOM: Core & HTML
Product: Firefox → Core
QA Contact: general → general
Whiteboard: DUPEME
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Whiteboard: DUPEME
Duplicate of bug: 268945
You need to log in before you can comment on or make changes to this bug.