When using the droid x magnifier to edit text on firefox mobile, the text blinker is placed at the end of the text instead of where the user desires.

RESOLVED WORKSFORME

Status

--
major
RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: johnsc301, Unassigned)

Tracking

Firefox 4.0
ARM
Android

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Android; Linux armv71; rv:2.1) Gecko/20110318 Firefox/4.0b13pre Fennec/4.0)

I am referring to when you click in the middle of a sentence and use the red circular magnifier. If try to add text to the middle of the sentence, it gets put at the end regardless. It happens on blogging sites or sites that use their own commenting box like facebook.

Reproducible: Always

Steps to Reproduce:
1.Type up a facebook comment.
2.Click in the middle of the typing.
3.Try to add to the middle (where you clicked).
Actual Results:  
The cursors always reverts to the end.

Expected Results:  
The cursor should stay where you put it.
Jay, could you try reproducing this on your Droid X?
OS: Linux → Android
Hardware: x86_64 → ARM
(Reporter)

Comment 2

7 years ago
In google.com search i get this as well. Also in typing this post. i was in horizontal while typing and the problem cropped up. But i shifted the phpne straight and was unable to get a keyboard zoom. I put the phone horizontal again and the magnifier is back and was working fine. Suddenly the magnifier was acting up again and now the cursor resets itself to the end again. I just pressed back to get out of the horizontal fullscreen keyboard and the cursor is normal again. very annoying!
(Reporter)

Updated

7 years ago
Version: Trunk → Firefox 4.0

Comment 3

7 years ago
Can someone having a droid x reproduce this ? I cannot reproduce it on Droid 2.

shadydogg2731, can you still reproduce this issue?
(Reporter)

Comment 4

7 years ago
Yep. I use launcher pro instead of the default droid home. Maybe that could be an issue?
(Reporter)

Comment 5

7 years ago
Yep. I use launcher pro instead of the default droid home. Maybe that could be an issue?
(Reporter)

Comment 6

7 years ago
My bad, just woke up^
I tested this on home and launcher pro. Problem persists on both.
A good way to test this is using m.facebook.com
Vertically trying to type a status yields no magnifier.
Horizontally brings it up. When horizontal, type something random like fdvbgcxbv then click in the middle with the magnifier. Type a. You'll see it puts a at the end.
I have android 2.2.1
(Reporter)

Comment 7

7 years ago
So the droid x magnifier problem appears in other apps too I've discovered. I think the facebook app is one.
(Reporter)

Comment 8

7 years ago
After an upgrade to android 2.3, the problem is gone. It must've been an android issue and not a fennec problem.
Marking works for me then. Thanks for the update!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.