Closed Bug 650693 Opened 12 years ago Closed 12 years ago

"From" name listed inconsistently in interface ... different in "From" columns vs in message header

Categories

(Thunderbird :: General, defect)

x86_64
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 243631

People

(Reporter: anon.e.mouse.bug, Unassigned)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.16) Gecko/20110322 Fedora/3.6.16-1.fc13 Firefox/3.6.16
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.15) Gecko/20110307 Fedora/3.1.9-0.38.b3pre.fc13 Lightning/1.0b3pre Thunderbird/3.1.9

So you get an e-mail from someone who is in your address list. Let's say the person's actual full name is John Smith ... let's say that you have the person in your address book as Johnny, and that person has their name configured in their own e-mail client as Smithy.

In your Thunderbird inbox, the "From" column will show:
Smithy

In the headers that appear in the message pane, the "from" field will show:
Johnny

This is an inconsistency without an apparent rationale.

Reproducible: Always
Already fixed on trunk (3.3).
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 243631
You need to log in before you can comment on or make changes to this bug.