Last Comment Bug 650749 - Fix xptcall on OpenBSD/powerpc
: Fix xptcall on OpenBSD/powerpc
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: XPCOM (show other bugs)
: unspecified
: All OpenBSD
: -- normal (vote)
: mozilla8
Assigned To: Landry Breuil (:gaston)
:
:
Mentors:
Depends on:
Blocks: openbsdmeta
  Show dependency treegraph
 
Reported: 2011-04-18 02:52 PDT by Landry Breuil (:gaston)
Modified: 2011-08-16 04:28 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Fix xptcall on OpenBSD/powerpc (16.38 KB, patch)
2011-04-18 02:52 PDT, Landry Breuil (:gaston)
benjamin: review+
Details | Diff | Splinter Review

Description Landry Breuil (:gaston) 2011-04-18 02:52:15 PDT
Created attachment 526686 [details] [diff] [review]
Fix xptcall on OpenBSD/powerpc

As of now mozilla segfaults on OpenBSD/macppc if the attached patch is not present. We're shipping it with thunderbird/seamonkey/firefox* ports. it makes the xptc{invoke,stubs}_asm_ppc_openbsd.s files use c++-style for comments, and sets AS to CC, as done for linux/ppc*.

Don't ask me to comment on why/how/where/when this patch came around... i have no idea.
Comment 1 Landry Breuil (:gaston) 2011-08-11 14:17:33 PDT
Oh, and this patch fixes the packaging error i was seeing in https://bugzilla.mozilla.org/show_bug.cgi?id=670719#c19. And it allows mozilla-central to run fine on openbsd/macppc, (with a bunch of other patches..) here's a proof : http://rhaalovely.net/~landry/stuff/ffx-8.0a1-openbsd-macppc.png (built on my ibook g4, running on my mac mini)

and the full build logs here : http://buildbot.rhaalovely.net/builders/mozilla-central-macppc/builds/46

Since this is not part of the regular mozilla builds and that patch can't break other parts of the tree, could this get commited before the next m-c->m-a shift ? That'll be one less patch to maintain for me...
Comment 2 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2011-08-16 04:28:26 PDT
http://hg.mozilla.org/mozilla-central/rev/f8a0d02f1257

Note You need to log in before you can comment on or make changes to this bug.