can't re-add through OpenSearch discovery a removed default search provider

RESOLVED DUPLICATE of bug 353056

Status

()

Firefox
Search
RESOLVED DUPLICATE of bug 353056
7 years ago
3 years ago

People

(Reporter: Lukasz Stelmach, Unassigned)

Tracking

4.0 Branch
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.0; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Windows NT 6.0; rv:2.0) Gecko/20100101 Firefox/4.0

Firefox 4 doesn't indicate availability of OpenSearch search plug-ins and sometimes doesn't offer them although they are available. It offers one for http://en.wikipedia.org but not for http://pl.wikipedia.org although both include the same "<link rel=" tag.

Reproducible: Always

Comment 1

7 years ago
(In reply to comment #0) 
> Firefox 4 doesn't indicate availability of OpenSearch search plug-ins and
> sometimes doesn't offer them although they are available. It offers one for
> http://en.wikipedia.org but not for http://pl.wikipedia.org although both
> include the same "<link rel=" tag.

This would imply that you already have pl.wikipedia.org installed; For me the results are the opposite way round as I am using en-US.

The availability glow was removed on purpose - bug 430627.
(Reporter)

Comment 2

7 years ago
(In reply to comment #1)

> This would imply that you already have pl.wikipedia.org installed;

No I have not.
So you don't see the 'Add "Wikipedia (pl)' entry in the search engine drop down?
(Reporter)

Comment 4

7 years ago
That is correct. However, I can see 'Add "Wikipedia (en)' when visiting en.wikipedia.org. Of course only while it's not already there.
Can you please create a screenshot with the search drop down open in this failing state?
(Reporter)

Comment 6

7 years ago
Created attachment 527748 [details]
FF4 can't discover OpenSearch data in Polish Wikipedia

The screenshot shows the fornt page of Polish Wikipedia and it HTML source with OpenSearch link tag present. However, "Wikipedia (pl)" is not available in the search box, neither as already installed nor as available for instalation.
I can't reproduce this issue. Can you please try if you still see it with a fresh profile (http://support.mozilla.com/en-US/kb/Managing+profiles)?
(Reporter)

Comment 8

7 years ago
Yes, although it is a profile of a second freshness. Polish FF comes with pl.wikipedia pre-installed in a fresh profile. After I removed it I can't bring it back.

Updated

7 years ago
Version: unspecified → 4.0 Branch
(In reply to Lukasz Stelmach from comment #8)
> Yes, although it is a profile of a second freshness. Polish FF comes with
> pl.wikipedia pre-installed in a fresh profile. After I removed it I can't
> bring it back.

Ah, so the problem seems to be that if a provider is installed by default and then removed (which doesn't really remove it, only hides it), it can't be re-added through OpenSearch discovery.
Summary: OpenSearch discovery doesn't work (sometimes, most of the time) → can't re-add through OpenSearch discovery a removed default search provider
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 353056
You need to log in before you can comment on or make changes to this bug.