Closed Bug 650817 Opened 9 years ago Closed 8 years ago

Search engines list misinterprets tap and pan

Categories

(Firefox for Android Graveyard :: General, defect, P3)

ARM
Android
defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: andreea.pod, Assigned: vingtetun)

Details

(Whiteboard: [fennec-6])

Attachments

(1 file)

Mozilla /5.0 (Android;Linux armv7l;rv:2.1) Gecko/20110317 Firefox/4.0b13pre Fennec /4.0
Device: LG Optimus 2X

Steps to reproduce:
1. Open fennec
2. Go to http://mycroft.mozdev.org/search-engines.html
3. Add more then 10 search engines from that page
3. Tap on the url bar
5. Tap on the search button

Scenario 1:
6. Pan the list to get to the last search engine

Expected results:
The list should pan without selecting any search engine.

Actual results:
When taping and panning the search engine that was tapped is accessed and loaded in the browser. Please see this video: http://www.youtube.com/user/qaioana#p/a/u/0/Poch7CwJMmo

Scenario 2:
6. Tap outside the search engines list (at the bottom of the screen)

Expected results:
The list should close and you should be in the awesome screen.

Actual results:
Taping outside is selecting the link that is under the list and the page is loaded.
Priority: -- → P3
Assignee: nobody → 21
Whiteboard: [fennec-6]
Attached patch PatchSplinter Review
The patch does not used the button onclick listener but TapSingle to ensure the click is not fired if a pan has happened.
Attachment #529466 - Flags: review?(mark.finkle)
Attachment #529466 - Flags: review?(mark.finkle) → review+
http://hg.mozilla.org/mozilla-central/rev/9f3466cf2163
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
The second scenario is still reproducible

Scenario 2:
6. Tap outside the search engines list (at the bottom of the screen)

Expected results:
The list should close and you should be in the awesome screen.

Actual results:
Taping outside is selecting the link that is under the list and the page is
loaded.

You can see this also in the video: http://www.youtube.com/user/qaioana#p/a/u/0/Poch7CwJMmo
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
After reading the steps to reproduce and tried on desktop, I think this is the behavior we want, the popup is closed on a mousedown by design.
Status: REOPENED → RESOLVED
Closed: 8 years ago8 years ago
Resolution: --- → FIXED
VERIFIED FIXED on:

Build Id: Mozilla /5.0 (Android;Linux armv7l;rv:6.0a1) Gecko/20110523 Firefox/6.0a1 Fennec/6.0a1 

Device: HTC Desire Z (Android 2.2)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.