Improve 'Reply' functionality with RSS Items

RESOLVED DUPLICATE of bug 271327

Status

Thunderbird
Message Compose Window
--
enhancement
RESOLVED DUPLICATE of bug 271327
7 years ago
7 years ago

People

(Reporter: Jeff, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.16) Gecko/20110319 Firefox/3.6.16 ( .NET CLR 3.5.30729; .NET4.0E)
Build Identifier: 3.1.9

The 'reply' action for RSS Items is only marginally useful. Firstly, when a RSS Item has focus, all three reply actions in the 'Messages' menu are disabled, but are available in the item's context menu. I doubt that is by design. In addition, selecting any of the three results in the same behavior- launching a compose message window with the 'To' field blank. This is effectively the same as the 'Forward' action, which itself is certainly useful.

What I would like to see is two actions on the menu - Reply and Reply to All. They would be activated by the presence of 'Mailto' tags in the body of the RSS Item. Some rss feeds (*cough*craigslist*cough*)act as analogs of mailing lists and replies are within the spirit of the protocol. If more than one tag is present and one can be identified as 'more important'(first or occuring in subject field?), that can populate the 'to' field when calling the reply action. In the case of reply to all, all the mailtos can be used.



Reproducible: Always

Steps to Reproduce:
1.select rss item
2.click on link in body of item
3.launch browser to view full item
4.highlight mailto link in browser and copy destination address to clipboard
5. return to thunderbird, compose new message
6. paste email into 'to' field.


Expected Results:  
ctrl-r to reply
mailto tag in item is used to populate 'to' field

With Craigslist specifically, the mailto tag doesn't even display in the body of the message. If it did, at least clicking on it would launch the 'compose message' window. As it is, every reply requires a round-trip to the browser.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 271327
You need to log in before you can comment on or make changes to this bug.