Last Comment Bug 650864 - TI: Assertion failure: isScriptFrame(), at jsinterp.h:330
: TI: Assertion failure: isScriptFrame(), at jsinterp.h:330
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: Jan de Mooij [:jandem]
:
Mentors:
Depends on:
Blocks: 619433
  Show dependency treegraph
 
Reported: 2011-04-18 11:04 PDT by Jan de Mooij [:jandem]
Modified: 2011-04-18 13:13 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (1.13 KB, patch)
2011-04-18 11:10 PDT, Jan de Mooij [:jandem]
bhackett1024: review+
Details | Diff | Review

Description Jan de Mooij [:jandem] 2011-04-18 11:04:26 PDT
The microformat tests in Mochitest-5 trigger this assert.
Comment 1 Jan de Mooij [:jandem] 2011-04-18 11:10:47 PDT
Created attachment 526763 [details] [diff] [review]
Patch

The problem was that the previous frame is a dummy frame and we should not attempt to get its script.
Comment 2 Brian Hackett (:bhackett) 2011-04-18 13:13:46 PDT
http://hg.mozilla.org/projects/jaegermonkey/rev/9d469a96c496

Note You need to log in before you can comment on or make changes to this bug.