Thunderbird deletes messages that the user didn't ask to delete

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: musiphil, Unassigned)

Tracking

({dataloss})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 2012-03-01])

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.16) Gecko/20110319 Firefox/3.6.16 ( .NET CLR 3.5.30729; .NET4.0C)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.15) Gecko/20110303 Thunderbird/3.1.9

I'm using an IMAP Gmail account. Often I delete a series of spam messages, skipping non-spam ones. Then often, very strangely, I find that some messages that I didn't delete have been deleted and moved to the Trash folder.

Another strange symptom that might be related is that a message that was opened and marked read spontaneously turns unread after a few seconds.

This is very dangerous because the user might unknowingly lose data.

Reproducible: Sometimes

Steps to Reproduce:
I experience this very often, but I haven't found a way to reproduce this in a reliable manner. Please report if you are aware of similar symptoms and can reproduce it.
Component: General → Networking: IMAP
Keywords: dataloss
Product: Thunderbird → MailNews Core
QA Contact: general → networking.imap

Comment 1

7 years ago
Seungbeom Kim, do you still see this problem when using version 9 or 10?

iirc, we've had reports of things like this in the past, but are now gone.
Whiteboard: [closeme 2012-03-01]
(Reporter)

Comment 2

7 years ago
Thank you for your interest. I don't think I've experienced the problem for a while; I had been sticking to Thunderbird 3, but recently upgraded to later versions.

If it has been fixed, can you please point to the relevant Bugzilla entry?

By the way, I still see messages turn "unread" in a few seconds after they are marked "read" automatically. They eventually turn "read" again if I wait for a few more seconds, though. I'd also like to be referred to the relevant Bugzilla entry for this, if any.

Comment 3

7 years ago
(In reply to Seungbeom Kim from comment #2)
> Thank you for your interest. I don't think I've experienced the problem for
> a while; I had been sticking to Thunderbird 3, but recently upgraded to
> later versions.
> 
> If it has been fixed, can you please point to the relevant Bugzilla entry?

Thanks for the feedback. I don't have a bug reference for you.


> By the way, I still see messages turn "unread" in a few seconds after they
> are marked "read" automatically. They eventually turn "read" again if I wait
> for a few more seconds, though. I'd also like to be referred to the relevant
> Bugzilla entry for this, if any.

please have a search of the bug reports https://bugzilla.mozilla.org/query.cgi
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.