Group locale dashboard reloads tables in locale language

VERIFIED FIXED in 2.8.1

Status

VERIFIED FIXED
8 years ago
8 years ago

People

(Reporter: paulc, Assigned: rrosario)

Tracking

unspecified
2.8.1

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
Post bug 638478, we're adding locale dashboards for groups.
The problem is that the tables loading through AJAX are showing in the locale's language. This is minor, hence filing separately.

STR:
1. Visit /en-US/dashboard/locale/de
2. Click on "This week", "All time", "Most viewed" or "Most recent"

AR:
Sad. Table headings and right-side actions are in German.

ER:
All is in English, since that's the page's language.
My only question is, why is the URL /en-US/dashboard/locale/de and not /en-US/dashboard/group/#id? Dashboards belong to a group, and the actual locale (the 'de') is passed is as a parameter to the dashboard. I could be in 10 groups that all have a localization dashboard and 5 of them could be 'de'.
(Reporter)

Comment 2

8 years ago
(In reply to comment #1)
> My only question is, why is the URL /en-US/dashboard/locale/de and not
> /en-US/dashboard/group/#id? Dashboards belong to a group, and the actual locale
> (the 'de') is passed is as a parameter to the dashboard. I could be in 10
> groups that all have a localization dashboard and 5 of them could be 'de'.
For posterity, this has been resolved as part of the blocking bug 638478.
(Assignee)

Updated

8 years ago
Assignee: nobody → rrosario
(Assignee)

Comment 3

8 years ago
https://github.com/jsocol/kitsune/commit/5b55c8f3bc9cc5ab6d27be71228bd4efe32031ca
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Verified dashboard headings and text [all except document names] match the language of the user's locale and not the locale of the dashboard.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.