[prod] - ISE :: DoesNotExist: Comment matching query does not exist.

VERIFIED DUPLICATE of bug 606504

Status

VERIFIED DUPLICATE of bug 606504
8 years ago
8 years ago

People

(Reporter: mbrandt, Unassigned)

Tracking

Details

(Whiteboard: [prod], URL)

(Reporter)

Description

8 years ago
Traceback (most recent call last):

  File "/data/www/django/input.mozilla.com/reporter/vendor/packages/Django/django/core/handlers/base.py", line 100, in get_response
    response = callback(request, *callback_args, **callback_kwargs)

  File "/data/www/django/input.mozilla.com/reporter/vendor/packages/Django/django/utils/decorators.py", line 76, in _wrapped_view
    response = view_func(request, *args, **kwargs)

  File "/data/www/django/input.mozilla.com/reporter/apps/input/decorators.py", line 43, in cached_view
    return f(request, *args, **kwargs)

  File "/data/www/django/input.mozilla.com/reporter/apps/website_issues/views.py", line 126, in single_site
    return jingo.render(request, 'website_issues/sites.html', data)

  File "/data/www/django/input.mozilla.com/reporter/vendor/src/jingo/jingo/__init__.py", line 78, in render
    rendered = render_to_string(request, template, context)

  File "/data/www/django/input.mozilla.com/reporter/vendor/src/jingo/jingo/__init__.py", line 96, in render_to_string
    return template.render(**get_context())

  File "/data/www/django/input.mozilla.com/reporter/vendor/packages/jinja2/jinja2/environment.py", line 891, in render
    return self.environment.handle_exception(exc_info, True)

  File "/data/www/django/input.mozilla.com/reporter/apps/website_issues/templates/website_issues/sites.html", line 13, in top-level template code
    href="{{ sites_url(form,**{name: value}) }}">{{ label }}</a>

  File "/data/www/django/input.mozilla.com/reporter/templates/base.html", line 65, in top-level template code
    {% block content %}{% endblock %}

  File "/data/www/django/input.mozilla.com/reporter/apps/website_issues/templates/website_issues/sites.html", line 63, in block "content"
    {% include "website_issues/includes/single_site.html" %}

  File "/data/www/django/input.mozilla.com/reporter/apps/website_issues/templates/website_issues/includes/single_site.html", line 30, in top-level template code
    {% for comment in cluster.secondary_comments[:4] %}

  File "/data/www/django/input.mozilla.com/reporter/vendor/packages/jinja2/jinja2/environment.py", line 371, in getattr
    return getattr(obj, attribute)

  File "/data/www/django/input.mozilla.com/reporter/apps/input/decorators.py", line 79, in __get__
    value = self.func(obj)

  File "/data/www/django/input.mozilla.com/reporter/apps/website_issues/models.py", line 39, in secondary_comments
    qs = self.comments.exclude(pk=self.primary_comment.pk)

  File "/data/www/django/input.mozilla.com/reporter/vendor/packages/Django/django/db/models/fields/related.py", line 300, in __get__
    rel_obj = rel_mgr.using(db).get(**params)

  File "/data/www/django/input.mozilla.com/reporter/vendor/packages/Django/django/db/models/query.py", line 341, in get
    % self.model._meta.object_name)

DoesNotExist: Comment matching query does not exist.


<WSGIRequest
GET:<QueryDict: {u'os': [u'vista']}>,
POST:<QueryDict: {}>,
COOKIES:{},
META:{'CSRF_COOKIE': '63e71bed44cea541a90ed81c818ff314',
 'DOCUMENT_ROOT': '/data/www/django/input.mozilla.com/reporter',
 'GATEWAY_INTERFACE': 'CGI/1.1',
 'HTTP_ACCEPT': '*/*',
 'HTTP_ACCEPT_ENCODING': 'gzip,deflate',
 'HTTP_ACCEPT_LANGUAGE': 'ru, uk;q=0.8, be;q=0.8, en;q=0.7, *;q=0.01',
 'HTTP_CONNECTION': 'Keep-Alive',
 'HTTP_FROM': 'support@search.yandex.ru',
 'HTTP_HOST': 'input.mozilla.com',
 'HTTP_USER_AGENT': 'Mozilla/5.0 (compatible; YandexBot/3.0; +http://yandex.com/bots)',
 'HTTP_X_CLUSTER_CLIENT_IP': '77.88.27.27',
 'PATH_INFO': u'/ru/release/site/http/barnesandnoble.com',
 'PATH_TRANSLATED': '/data/www/django/input.mozilla.com/reporter/wsgi/reporter.wsgi/ru/release/site/http/barnesandnoble.com',
 'QUERY_STRING': 'os=vista',
 'REMOTE_ADDR': '10.8.81.200',
 'REMOTE_PORT': '43783',
 'REQUEST_METHOD': 'GET',
 'REQUEST_URI': '/ru/release/site/http/barnesandnoble.com?os=vista',
 'SCRIPT_FILENAME': '/data/www/django/input.mozilla.com/reporter/wsgi/reporter.wsgi',
 'SCRIPT_NAME': u'',
 'SERVER_ADDR': '10.8.81.21',
 'SERVER_ADMIN': 'webmaster@mozilla.com',
 'SERVER_NAME': 'input.mozilla.com',
 'SERVER_PORT': '80',
 'SERVER_PROTOCOL': 'HTTP/1.1',
 'SERVER_SIGNATURE': '',
 'SERVER_SOFTWARE': 'Apache',
 'mod_wsgi.application_group': 'input.mozilla.com|',
 'mod_wsgi.callable_object': 'application',
 'mod_wsgi.handler_script': '',
 'mod_wsgi.input_chunked': '0',
 'mod_wsgi.listener_host': '',
 'mod_wsgi.listener_port': '80',
 'mod_wsgi.process_group': 'input',
 'mod_wsgi.request_handler': 'wsgi-script',
 'mod_wsgi.script_reloading': '1',
 'mod_wsgi.version': (3, 3),
 'wsgi.errors': <mod_wsgi.Log object at 0x2b9ea89879f0>,
 'wsgi.file_wrapper': <built-in method file_wrapper of mod_wsgi.Adapter object at 0x2b9ea89aff30>,
 'wsgi.input': <mod_wsgi.Input object at 0x2b9ea8987cb0>,
 'wsgi.loaded': datetime.datetime(2011, 4, 19, 2, 34, 50, 822414),
 'wsgi.multiprocess': True,
 'wsgi.multithread': False,
 'wsgi.run_once': False,
 'wsgi.url_scheme': 'http',
 'wsgi.version': (1, 1)}>

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 606504
(Reporter)

Updated

8 years ago
Status: RESOLVED → VERIFIED
(Assignee)

Updated

8 years ago
Component: Input → General
Product: Webtools → Input
You need to log in before you can comment on or make changes to this bug.